}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello,

I bought MoO2 during the holidays and I'm having a nostalgic blast. There are however two little details that I would like to fix. Both concerning the space battle screen.

A. The mouse scroll speed is extremely fast, making it difficult to centre the screen on a ship.
B. The animations are again, extremely fast. I can't really see what's going on but because of the scrolling speed I always end up playing battles in Auto mode.

I know these values were programmed to follow the processor clock, I'm wondering if there's a DOSBox tweak that can fix this.

Thanks.
avatar
eregimbald: /snip
I tried to use the CPU settings to fix the scrolling speed, but couldn't. However, I don't know if I ever tried zarakon's settings and he said it helped:

http://www.gog.com/en/forum/master_of_orion/moo2_dosbox_config/post3

I'd be interested to know if this works for you.

Alternatively you can click the mini-map to move around the battle screen and avoid the scrolling issue all together.

I never found the animations to be so fast I couldn't see what was happening, but it is possible your computer is even faster. Maybe the above cpu cycles would help you there too. I believe there is also a toggle option concerning "fast animations" in battle sequences in MoO2 is there not? If so, make sure it is disabled.
Post edited December 28, 2011 by crazy_dave
avatar
eregimbald: /snip
avatar
crazy_dave: I tried to use the CPU settings to fix the scrolling speed, but couldn't. However, I don't know if I ever tried zarakon's settings and he said it helped:

http://www.gog.com/en/forum/master_of_orion/moo2_dosbox_config/post3

I'd be interested to know if this works for you.

Alternatively you can click the mini-map to move around the battle screen and avoid the scrolling issue all together.

I never found the animations to be so fast I couldn't see what was happening, but it is possible your computer is even faster. Maybe the above cpu cycles would help you there too. I believe there is also a toggle option concerning "fast animations" in battle sequences in MoO2 is there not? If so, make sure it is disabled.
The minimap!! Arghh why didn't I think of that..?

Well, on auto the animations are not impossible to follow but let's say I have 10 missile ships firing their load one after another, the screen will move around at seizure inducing speed while I hear something similar to a chain-gun firing.

The auto combat AI isn't so bad, it's just when my beam ships start crowding Anterran ships that I find it retarded.

I'm currently playing a game on Impossible and it's not going too well :-/

Thanks for the settings I'll try them out tonight.
avatar
eregimbald: I'm currently playing a game on Impossible and it's not going too well :-/

Thanks for the settings I'll try them out tonight.
Best of luck!, let me know how it turns out (both the game and the settings)!
Alright, I modified a few settings but I'm not sure what any of them do. Like graphic processing optinos and the like.

The mouse sensitivity is what helped the most.

And for the game, the Elerians decided it was time to fk me up. My ship design wasnt great and I forgot to get shields and a decent (fusion) engine. So I can't even defend my own planets.

(I tried another game, the Klackons popped up, demanded one of my systems, I said no, they declared war and wiped me out)

I'm back to hard until I really figure out how to beat impossible.
avatar
eregimbald: Alright, I modified a few settings but I'm not sure what any of them do. Like graphic processing optinos and the like.

The mouse sensitivity is what helped the most.
Glad something helped! Did you use zarakon's sensitivity settings? Or a different one?
avatar
eregimbald: And for the game, the Elerians decided it was time to fk me up. My ship design wasnt great and I forgot to get shields and a decent (fusion) engine. So I can't even defend my own planets.

(I tried another game, the Klackons popped up, demanded one of my systems, I said no, they declared war and wiped me out)

I'm back to hard until I really figure out how to beat impossible.
Aye, I think I mostly play on average and hard myself. I feel a touch constrained on impossible because there are fewer strategies that work well given how the games play on impossible settings so I feel like there is less choice on what to do.
Yes, I used all of his settings but the only difference I noticed was in the mouse scroll speed.

The rest was working perfectly fine before
avatar
eregimbald: Yes, I used all of his settings but the only difference I noticed was in the mouse scroll speed.

The rest was working perfectly fine before
Thanks for the info!
If you have at least a missile base at each colony, you're less likely to be attacked directly. Once you have battlestations up, you're secure for a while in the mid-game.