It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi,

The DOS Version of the game has some sound issues :/
I tried many things, I've changed the IRQ to 5 AND 7, it was originally set to -1 (wtf?)
DMA_8_BIT (and 16) were also set to -1.

I tried many things, but nothing worked so far :/

Also... I am not sure if I have the same problems as the others.
Is the Music quality in MoO2 just bad?

It's allways popping and cracking.
And there's always static :/

I generally like the Music of the Game...so I don't want to turn it off :I
Post edited January 20, 2017 by RonnieTreibholz
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hey Ronnie, I know this post is from a while ago but this thread is still on the front page so I'll add my two cents:

I've experienced the same issue under the following circumstances:
When I have another application open that can potentially interface with my sound card. Example: Firefox is open with a tab on a youtube video. Closing the application and restarting MoO2 generally fixes the issue.

Randomly, no rhyme or reason. This can usually be fixed, for myself at least, by hitting Alt+Enter to Full Screen / Window the game, then hitting it again to bring it back to its original state.

Hope that helps!
avatar
psilontech: Hey Ronnie, I know this post is from a while ago but this thread is still on the front page so I'll add my two cents:

I've experienced the same issue under the following circumstances:
When I have another application open that can potentially interface with my sound card. Example: Firefox is open with a tab on a youtube video. Closing the application and restarting MoO2 generally fixes the issue.

Randomly, no rhyme or reason. This can usually be fixed, for myself at least, by hitting Alt+Enter to Full Screen / Window the game, then hitting it again to bring it back to its original state.

Hope that helps!
Thanks!
I will look into that.
Well...so far I didn't find a fix :/

But thanks! I hope it'll work now! <3
Try this. It works for me: scaler normal2x and double buffering disabled. If I set scaling engine to normal3x, hq2x etc, sound is crackling.
https://www.gog.com/forum/master_of_orion_series/moo2_sound_popping/post8

Or this:
https://www.gog.com/forum/master_of_orion_series/moo2_sound_popping/post11
Post edited March 19, 2017 by kjx