It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello.
I installed the games and started MoO from the "installation complete" launcher. Everything worked perfect until I heard I got a Gtalk message so I quit MoO (Quit to Dos.), answered the message and started MoO again with the desktop shortcut. That got me DosBox MoO in a window. Then I tried the shortcut on the start meny with the same result.
Might this be a Vista 64bit, DosBox or MoO problem? Any help would be appreciated.
This question / problem has been solved by Vanionimage
Have you tried hitting Alt+Enter while DOSBOX was focused? That should give you fullscreen mode.
avatar
Vanion: Have you tried hitting Alt+Enter while DOSBOX was focused? That should give you fullscreen mode.

Thank you! That worked.
Although this seem to occur every time I start the game. I can live with pressing Alt+Enter, just a bit curious what the problem might be?
Glad I could help!
Are we talking about Orion 1 or 2? There might be a slight hickup in the config files, I haven't checked myself yet.
Yea just open the config file with notepad and see if it has a fullscreen= line, just make sure that is set to true.
Is there a way to do pixel doubling with DOSBox? I have a screen that's exactly twice 640x480, why not scale up the image so I can get something sharper, instead of having my monitor blur it up as it upscales?
MoO 1 and it say fullscreen=true in the config file.
I have some progress because now it doesn't happen every time so I'm more or less convinced it's a Vista problem. Just like about everything else. Stupid Vista.
I"m having a problem connecting with my buddy for moo2 online play. We are connecting via the internet not a lan game. I've given my buddy the ip, but he isn't able to find my game. I didn't see anywhere that we couldn't connect via the net, and my ip addy is correct. Is there somthing I'm missing here? I am using the gog network host application for dosbox included with the game.
I'm using a 2wire 3800HGV-B Gateway. Is it possible that the gateway is killing the connection? I'm not sure how to let dosbox through the gateway if it is the problem. Any help would be appreciated.
MOO is running fine except for one small problem. It won't go fullscreen. I'm not sure why. The window it is in covers the whole screen, but it the game itself stays at the smaller size. I don't have this problem with MOO2. Is there a change I can make to DosBox to fix this?
Attachments:
moo.png (102 Kb)
avatar
TimRPalmer: MOO is running fine except for one small problem. It won't go fullscreen. I'm not sure why. The window it is in covers the whole screen, but it the game itself stays at the smaller size. I don't have this problem with MOO2. Is there a change I can make to DosBox to fix this?
There's a setup program in the game folder. Set it to DDraw\fullscreen\maintain aspect ratio, that should do it.

If you find it performs too slow, raise dosbox's cycles with ctrl+F12.
Post edited March 28, 2013 by Avogadro6
avatar
TimRPalmer: MOO is running fine except for one small problem. It won't go fullscreen. I'm not sure why. The window it is in covers the whole screen, but it the game itself stays at the smaller size. I don't have this problem with MOO2. Is there a change I can make to DosBox to fix this?
avatar
Avogadro6: There's a setup program in the game folder. Set it to DDraw\fullscreen\maintain aspect ratio, that should do it.

If you find it performs too slow, raise dosbox's cycles with ctrl+F12.
I'm having this same issue, can you explain where the setup file is? I'm unable to find anything with setup in the name in the folder
avatar
Avogadro6: There's a setup program in the game folder. Set it to DDraw\fullscreen\maintain aspect ratio, that should do it.

If you find it performs too slow, raise dosbox's cycles with ctrl+F12.
avatar
sleeveofroses: I'm having this same issue, can you explain where the setup file is? I'm unable to find anything with setup in the name in the folder
There should be a shortcut titled "Launch Graphic Mode Setup" in your Master of Orion folder. This lets you choose DDraw/fullscreen/maintain aspect ratio like Avogadro6 mentioned.

The setup file which was mentioned earlier is the "dosboxMOO1.conf"-file and needs to be edited with Notepad or something similar.
Post edited March 29, 2013 by Remit
I'm trying to edit this file. I don't have much experience with DosBox. Which line am I supposed to change? I don't see aspect ratio... I see screen resolution and I tried changing it to my native 1680x1050... Where do I put "DDraw\fullscreen\maintain"
What are you talking about, a setup file in the main folder about running it fullscreen?

I bought this game in 1992, and I'm still using the same copy from 21 years ago. I can assure you that the game does not come with any configuration stuff relating to direct draw etc.

is there something I'm missing? Are you supposed to get some kind of extra program other than DOSbox and Moo1?

I have both, and so far, there's no way to get it to display full screen without distorted aspect ratio that I can figure out. Nomatter how i config the dosbox configuration file, with aspect=true, setting the resolution to 320x200 (which I guess my monitor can't support, duh).

it's either distroted full screen or itsy bitsy windowed mode....

Kindly explain this configuration program in the game directory and where I can get it.
avatar
Slorrin: is there something I'm missing? Are you supposed to get some kind of extra program other than DOSbox and Moo1?
It's a dinky little configuration program that GOG supplies so you don't have to manually edit the dosbox.conf file.

avatar
Slorrin: I have both, and so far, there's no way to get it to display full screen without distorted aspect ratio that I can figure out.
The following works for me:

fullscreen=true
fullresolution=desktop
windowresolution=original

aspect=true
scaler=normal2x

output=overlay
Otherwise check your GPU and/or monitor scaling options.