It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I have a relatively new laptop with an AMD A10-5745M and a Radeon R7 M260. Both of these far exceed the system requirements, and it shows- the game runs at a high FPS regardless of what graphical settings I use. However, there is one thing I can't figure out- the game makes my laptop run very, very hot. The fan has drowned out the dialogue on some occasions, and I'm worried my laptop may overheat. It's only Mageunner that does this- other games run about as well as you'd expect on midrange laptop hardware.

Has anyone else had this issue? If so, how did you fix it?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
pokenutter: [...] the game runs at a high FPS [...] makes my laptop run very, very hot. [...]
These two are often related, or rather, your laptop is getting hot working at full capacity to render needlessly high framerates. You need to limit the FPS by some means. Enabling vsync locks the game at 60fps, though I don't remember if the game has an option like that built in.
avatar
pokenutter: ... If so, how did you fix it?
In the Options menu under Video is a switch to turn "Vertical Sync" On. As Sufyan said, the high temperature could derive from too high framerates.
Also check the game's config file (it's usually in \Users\<Username>\My Games\Magrunner\YoshiGame\Config\)
Open YoshiEngine.ini with any text editor and make sure this option is set: bSmoothFrameRate=TRUE
Post edited September 17, 2014 by DeMignon
avatar
pokenutter: I'm worried my laptop may overheat. It's only Mageunner that does this- other games run about as well as you'd expect on midrange laptop hardware.

Has anyone else had this issue? If so, how did you fix it?
Sorry for late answer - hope it might still be useful for someone...

If it's graphics chip (GPU) that runs too hot it could be too high a framerate like Sufyan and DeMignon suggested or it could be because of intensive physics calculation Magrunner is using. That would explain why (almost) no other game is causing it.

It's possible (at least on Nvidia, not sure about Radeon) to switch the physics library to use either GPU or CPU. (If it's already set to CPU and it's the CPU that is overheating, this could be the same problem on the other chip.)

Third possibility is more of a longshot, but it actually happened to me:

I bought a customised Clevo laptop and it ran very hot. When I opened the case to clean the coolers, I noticed that one of the fan intakes (on GPU side, IIRC) had a sticker pasted over it, blocking the fresh air from getting in. It was a black sticker on the inside, not visible from outside. When I removed it, the laptop cooled down immediately.

Weird, but true. And from what I've found on the Net, it happened to other people too (esp. with Clevo laptops).
Worth checking in any case.
Post edited December 02, 2014 by JJack