It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Okay. So, after buying this game, i attempt to download the installer and run it. At first, it is running fine. Then, after 30 seconds, the installer stalls out and the C++ redistributable described in the below post pops up. After that, I have to go and end the task. After looking at the forums, I tried running it as administrator several times to no avail. I even tried to redownload the installer in an effort to see if that fixed the problem (it didn't). I am at my wit's end in regards to this game. Please help.

Edit: Scratch all that. I (somehow) managed to get it working with the below method.
Post edited June 09, 2015 by BowToMe
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hi. Sorry for the late reply!

I'm glad everything is working now.