It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I can't find it
w3stone: I can't find it
In the Main Menu, select Options, then Controls, then at the bottom select 'Other' and you will find the option to enable Subtitles. An odd place to put it, for sure.