It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Original source: https://www.gog.com/forum/general/directdraw_fix_configurations

Hey guys, inspired by this other thread I found a way to make MAX 2 work again. I'm running this game on Linux under Wine, so maybe these problems were specific to me and they don't happen on Windows. In any case, here is what to do in order to make the game work on Wine (also applies to Windows!!) Usually for these kind of problems DXWND is able to fix it for me, but this time it couldn't hook Ddraw for some reason, it became extremely slow.

1) Download ddwrapper: http://bitpatch.com/ddwrapper.html

2) Put its files inside the game's directory (DDRAW.DLL and AQRIT.CFG)

2B) Additional step for Wine only: using Winecfg, add new library override for MAX2.EXE for ddraw.dll (you need to type it, it's not available for quick selection, a warning will appear, click Yes) set for "Native then Builtin"

3) Open AQRIT.CFG and paste these values there:

RealDDrawPath = AUTO
BltMirror = 0
BltNoTearing = 1
ColorFix = 0
DisableHighDpiScaling = 1
FakeVsync = 1
FakeVsyncInterval = 20
ForceBltNoTearing = 1
ForceDirectDrawEmulation = 1
NoVideoMemory = 0
SingleProcAffinity = 1
ShowFPS = 15

3B) If it works, you'll see a small box in the corner showing the framerate, it's a sign that the wrapper it's active ("hooked")

4) Run the game directly from MAX2.EXE Should be working now. Couldn't find a way to make "forced Vsync" to work, my framerate still fluctuates a lot particularly when I move the mouse, but it's much more under control than before.

Additional fix for touchpad or mouse sensitivity issues: (Linux only)
If you feel your mouse movement is very "touchy" or if it has a sort of "deadzone" like it doesn't register small movements, or diagonal movement, this fix should help you. This applies to other games like World of Warcraft or Icewind Dale.
1) Open a terminal window, run this command there: export SDL_MOUSE_RELATIVE=0
2) Without closing the same terminal window, run Wine from there: "wine explorer"
3) With explorer open, go to game's folder and start MAX2.EXE
4) "Virtual Desktop" option is not needed, game goes into fullscreen stretched
5) If mouse is still overly sensitive, try working around with XINPUT using these commands:
xinput list
xinput list-props <device number>
sudo xinput --set-prop <device> <property name or number> <value desired>
For my specific touchpad, these values worked not greatly but still better than before:
Device Accel Profile (262): 0
Device Accel Constant Deceleration (263): 2.000000
Device Accel Adaptive Deceleration (264): 4.000000
Device Accel Velocity Scaling (265): 6.000000

This is the only game to date which DXWND was not able to help me, I wonder what kind of sorcery the developers did with DirectX/DirectDraw in this game LOL
Oops, forgot to mention another error that happen on Linux Wine: game doesn't even start with the "screen init failed" error message. You gotta hex edit MAX2.EXE and change the value at address 69D2F from "05" to "00"
This makes the EXE bypass DirectDraw version verification.
Infinite blessings and gratitude for all nerdy people out there who figure this stuff out for us xDDDDDD
Hi,

I run MAX 2 on Windows 10 with any issues so I'd assume it's a Linux only issue.
Missed the reply... Do the mouse works 100% fine on your end? Or is it kinda loose?
edit: Playing the campaign for the very first time ever, only played free missions before... Couldn't even figure out how to win the very first mission xDDD What a boring way to start a game, I don't know what the devs were thinking... Do I have to hunt down and kill every Scout on the map to finish the first mission? That will take a looong time with slow tanks... Wow
Post edited October 21, 2019 by FeelingShred
WinXP dinosaur here.

Never had any issues with MAX2. Beware though that GOG sells v1.0 while the last patch is 1.4.

https://www.gog.com/forum/m_a_x_series/max2_patch_140