It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

If, for whatever reason, you wish to patch M.A.X. 2 to the latest version, you can find all of the latest patches on Interplay's official site under the M.A.X. 2 support page. The changelog claims to fix a couple of problems with the game, such as one of the missions not finishing, and a few other bugs. It's quite possible this will not work with the GOG version of M.A.X. 2 as I am not sure which version the GOG release is.
If you do download and install any of the patches on that page, keep in mind that you do so at your own risk. I am merely posting this here for the curious. Supposedly the last patch for M.A.X. 2 broke multiplayer support, which I cannot confirm. However, given the state of M.A.X. 2's multiplayer at this point and it's lack of popularity, it's probably not much of an issue.
Post edited March 14, 2010 by snarboo
The official 1.4 patch causes the gog version to request a cd to play ;-P. Too bad, cause according to the changelog it fixes a lot of annoying bugs (even in single player), like units firing into thin air after an enemy has been destroyed by one of them after the turn change.

I would be cool if the team patched this version of MAX2.
Moreover, the official Interplay patch 1.4 makes the campaign unable to load (though scenarios run fine). It says Wrong save file - can't load.
Post edited July 17, 2014 by Rodor
I just tried the official patch 1.4 on the current version of the game and it works, without requesting the cd. It might be worth a try.

note: I tried the 1.3 uk patch before it, but it didn't work at all.
OK, I checked again and the method to get MAX2 v1.40 is:
- install game from gog
- apply UK patch to v1.30
- apply US patch to v1.40

After this the game works ok from what I saw.
I just installed MAX 2 from the original CD"s I bought way back in like 2002 or something. It worked from the get go when I ran the setup.exe from the CD. Installed the patch 1.4 US and it doesn't ask for the CD.

I loved this game back then. Mind you , I beta tested it and loved it then also.