It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


The predecessor of this game (Lume) was also available under Linux, at least in the Hublestore.
Also State of Play promised an Linux Port of Lumino City (see thread on steamforum).
Unfortunately this game runs with Adobe AIR, and Adobe dropped their support for this platform in 2011. In my opinion we are out of luck getting an native version for the penguin.

So i tried installing the version using wine 1.6.2. It works like a charm.
* The installer gave me some errors about arrays, but installed the game.
* The game itself starts without errors and does not need any native DLL overrides.
* I have experienced no graphical errors.
* No sound stuttering.
* Switching between fullscreen and window works.#
* Saving and loading savegames also works.

It's a great game and i would recommend you to buy and play it. If State of Play will release an native Linux Port i will buy it again. :-)
Now that I have played through the game, I've noticed one maybe two problems with my installation under wine:

1. The Spinner House: After 2 spins the screen fades to black, the scene comes back again and Lumi stands in front of the house, irrespectively of where she has been previously and she can't move anywhere. The only workaround for me was to return to the Menu and then resume the game.

2. The Moving City right after the Spinner House the game ended with the Words "Luminocity will soon be complete, thanks for playing". I did found no way to fix this error in game.

So i started my real Windows, installed Luminocity via GOG Galaxy, copied the savegames from the Wine installation to the Windows installation (hint: you find them in %APPDATA%) and played the rest of the game under Windows. None of the 2 Issues mentioned above occurred to me there.

Out of curiosity i've booted back to Linux and overwrote the wine Luminocity installation with the files from GOG Galaxy Client. That also solved both problems.

Conclusion: I think i installed an old and buggy version of the game by accident and wine emulation runs perfect for this game. Maybe i spend some time to analyse this issue in n scientific ways...