It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

Hello again.
On my laptop with Windows 7, I installed Lords of the Realm 2, but whenever I try to run the game, it looks fine for a moment, then after a few seconds will change to a rainbow bright drug trip looking thing. If you have ever tried to run starcraft, worms world party, or Age of empires 2 on vista you will probably know what im talking about.
It works fine on my windows vista computer (save the multiplayer problem i posted earlier)
I have tried alt-tabbing out, and that doesnt work. i also tried the "Graphic Mode Setup" program they talked about in the game support page, but i think thats for LOTR 1, and thus didnt work either.
i have contacted support about this problem a few days ago (MA0090000048), and i know they are in the UK and this is probably not a common problem, so i figured while i wait for them to contact me, id ask here too.
Thanks to anyone to can help :)
PS: it wouldnt let me take a screen shot for some reason, so thats why the horrible camera pic.
This question / problem has been solved by Qbiximage
Buczek: I"ve got problem withm my LOTR2 on my laptop with win 7. When i start the game is in small window and i dont know what i have to do with this.
Same problem here.

I wasn't able to fix this issue in Tzar either...however with Tzar I managed to get used to the window size.

Lords II is a bit too small.

Another thread on here has an enlargement fix for Lords I.
Just fixed it.

Someone in another thread mentioned it had to do with scaling in Catalyst (if you're using an ATI/AMD/Radeon video card). He said he fixed it by turning GPU Scaling on but I fixed mine by turning GPU Scaling off.

Now Lords II fills my whole 16:10 monitor.