It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I play using a controller, and if I don't remember to move the mouse every few minutes the screen saver starts! Is there a way to prevent that, other than disabling the screen saver?

Other games I play with a controller don't have that issue.

OS: Windows 10 (fully updated)
Gfx: Nvidia Geforce 960 (drivers fully updated)
Controller: Sony Dualshock 4
Turn off screensaver ;)
kominikx: Turn off screensaver ;)
So you suggested the one thing I said "except" about, I see what you did there. :p

Even that doesn't help much though. After 30 minutes, the screen goes black because of my power settings. There has to be a better option than changing the power settings every time I want to play one game.
Well ;)

You might check advanced power settings or settings for the controller itself.
I do hot have controller like you, only joysticks and no problems at all.
Or you can search for some script or something that will emulate mouse moves, we are using something similar at work to prevent screensaver on PCs in domain.