It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi GOG Communty

I bought the game a few days after its release and started playing the adventure quietly.

Except that the achievements hardly unlock.

I have to do a game check for Galaxy to download about 90 MB of files and usually the next achievements work.

If I quit the game, I have to do it again to have a chance to get the achievements working.

I have contacted support in my native language, but the person has either given up or is on vacation. (no more answers, I hope it's the second case) after we tried several manipulations that didn't give anything (he even unlocked me some achievements made manually)

I tried to uninstall / reinstall the game as well, knowing that it made me lose my save. :(

Also installing by downloading the offline setup via internet directly. I have the same problem.

Have you found a trick to have acheivement ?
Do you use MSI afterburner or RivaTuner statistics? If I have them active when launching the game, the overlay doesn't load and it only syncs cheevos after a while, as you say. So what I do is shut down these two programs, start the game so the overlay starts properly, then once I'm in-game I boot them back up (for temp/fan control of my GPU and also RivaTuner's framerate limiter).