It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

high rated
Apparently a lot of people on Steam have encountered this problem, so I thought I would head off the questions by posting this workaround fix that I found on the Steam forums.

To get past the gargoyle section, turn off dynamic light quality in the pcconfig file. You can turn it back on after completing that section.
+1 Never encountered this myself, but thanks for the info!
Thanks for this! It actually didn't work when I did just that line, but then I also set shadows and bloom to 0 as well on a whim. Did the trick.
You have my thanks, it worked for me with setting DesiredDynamicLightQuality to 0.

But, god, it's ugly. I wish there was some kind of patch or anything.
Thank you!
For those who'd rather not click the Steam link:

*Go to C:\Documents and Settings\your username\Application Data\WB Games\LEGO Harry Potter\ (on XP)
or C:\Users\your username\Appdata\Roaming\WB Games\Lego Harry Potter\ (on Win8)

*Find a file called pcconfig.txt, back it up (I just saved a copy on the desktop, to use whenever needed), and then change DesiredDynamicLightQuality to 0 (near the bottom of the file). That is basically what is causing the problems. Although I read in some forum post or another, that Tt answered someone who contacted them, to change everything below MouseSensitivity to 0, so if you want to be extra sure...

That will cause all the lights to look weird, but at least the game doesn't crash anymore.

*After finishing the level, follow the same path again and replace pcconfig with the one you backed up earlier (you did back it up, right?), to get your original settings back. You do have to quit the game and restart it for it to work of course. Just sayin'.