It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm currently playing Legacy of Kain: Soul Reaver, and am having a very frustrating time with the keyboard controls. It's not that they're bad -- they are, as far as I'm concerned, but that's not the problem -- but rather that for some reason the controls seem to sometimes have a significant lag in responding to key -presses and -releases. The result is that all too often Raziel ends up running into a wall, or a group of enemies, or into a pool of water, or off of a ledge that I'm supposed to be navigating, all because the keys either respond well after I press them or continue to act as though I'm still pressing them well after I stop.

I'm running on Windows XP, SP3, I believe.

In case it's relevant, I've rebound the keys such that "impale/grapple" is bound to "w", camera rotation is controlled by "q" and "e", crouch is "shift" and the glyph menu is opened with "r". Movement is controlled by the arrow keys.

Has anyone else encountered this issue? What might I do to solve it?

I'll note that it is possible that the problem lies with my computer or its keyboard: while I'm only confident of having seen the issue with Soul Reaver, and only since installing it, I may have seen it briefly appear on one occasion in another game; I'm not greatly confident of that, however, and attempts to reproduce it in that game failed. The problem occurs often in Soul Reaver.

Only after posting did I notice that there was an option to mark a post as a "question" or "problem", and I don't see the option in the editing window -- would a mod please mark it so, if the option is available?

My apologies for the oversight -- I'm afraid that I don't use this forum often. ^^;
Post edited December 27, 2013 by Thaumaturge
same problem here!
One thing I'd recommend would be to remap the movement keys to IJKL, if you're right-handed. It may not fix the problem, but it might also help. Most keyboards have multitap issues -- which is especially true if you're playing on a laptop or netbook -- and the arrow keys are particularly troublesome in that regard. I used to have that problem with most games until I started binding the movement keys to ordinary alphanumeric character keys (namely, the aforementioned IJKL), and that seemed to solve the problem, so much that I do that from the get-go, as soon as I install a third person game that has movement mapped to the arrow keys by default.

Other than that, Soul Reaver is an old game, and the controls aren't as fluid as one might be used to, if we only played more recent titles, so do take that into account.
Post edited February 02, 2014 by groze

Thank you. ^_^

As it happens, I ended up contacting GOG's technical support, and it looks as though the problem may have been a corrupt DirectX installation, if I recall correctly.

As to the controls themselves, now that the problem has been addressed they're not terribly unresponsive. Nevertheless, I haven't spent much more time playing the game: I'm just finding the console-style control mechanism (including the camera mechanics, for that matter) to be too awkward for myself, especially when one starts to reach jumping puzzles. :/


I don't know how relevant -- or even applicable -- any of it is, but let me copy in the list of things to try that GOG support sent to me (edited slightly to remove a reference to my specific graphics card, since I don't know what card you have):

1) Make sure that your Windows user account has Administrator privileges, then right-click game's shortcut and select "Run as Administrator".

2) Create a folder with a simple name and path (like: C:\GAME\). Afterwards install the game into it.

3) Install the June 2010 DirectX runtime package, then use the DirectX web installer, as your current DirectX may have become corrupt over time. You can find it here:

4) Make sure that User Account Control is disabled in your operating system. To do this, go to Start -> Control Panel -> User Accounts and Family Safety -> User Accounts -> Change User Account Control settings. Move the slider to the lowest position ("Never notify") and click OK. Now reinstall the game by right-clicking the installer and using “Run as Administrator”, then launch the game with “Run as Administrator” again.

5) If the above don't help, right-click the game's shortcut, go to Properties -> Compatibility and try different compatibility modes before attempting to launch the game again.

6) Please update your graphics drivers.

(It was #3 that worked for me, I believe.)
Post edited February 12, 2014 by Thaumaturge