It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I tried running Late Shift but just got a black screen. If I clicked then I got the message LateShift.exe has stopped responding.

I tried looking for a fix but could only find answers for the Steam version. This recommended turning off the overlay if you have a nVidia card. So I did this, but no joy. Then another suggestion was turn off the Steam overlay, obviously I was using GOG Galaxy so this wasn't an option... however a little digging in the Galaxy settings and I found an option to turn off Galaxy's overlay and hey presto.. the game is working.