It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

now the videos a stuttering :P

Please be caution - use my steps at your own risk!

Hope someone can confirm it that the ingame 3d graphics works without flickering mouse or slowndowns!


What i did:

1) installed nglide 1.02 (don't know if its nesessary)

2) install LOL2

3) loading and extract from this website:

4) copy glide2x.ovl (DOS) and glide2x.dll (win9x)

to the C:\Lands Of Lore 1 and 2\DOSBOX (Folder)

(at his point i cant activate the ingame 3d option > its greyed out)


3) loading DOSBox SVN Daum from 25. Jul.2013 7z file

called: 20130725.7z

extract all files and copy & and replace all files in
C:\Lands Of Lore 1 and 2\DOSBOX

5) run the game

6) enable the "Hardware acceleration" Option

With these steps the ingame graphics will run without flickering mouse and slowdowns.

Downside: the movies are stuttering...

BUT: maybe some will find a solution for that.

Then some people need to play the game if the game runs 100% wihout glitches
Post edited September 20, 2013 by Mappi75
I tested your settings on my machine. Game works fine without framerate drops. The mouse flickers a bit but nothing that breaks the game.

The cutscenes work fine for me too. So far the best config for 3dfx for my setup.(winxp)
I am unable to get this to work. "Hardware acceleration" remains greyed out for me. Are there any DosBox settings I could try changing? At least all the Glide emulation settings are switched on.

Isn't step 4 cancelled out by installing that version of DosBox afterwards, as it contains glide2x.ovl and flide2x.dll also and you instruct to replace all the old files?

edit: I figured it out. What I needed to do was to change part of the shortcut to start the game from where it says "dosboxLOL2_single.conf" to "dosboxLOL2_3dfx.conf".
Post edited November 14, 2013 by timotaka
I cant get this to work.
I get a long line of red text and then the DOSBOX closes.
I think it might have to be related to the amount of memory
that it is using. Does anyone know where to look for
the master DOSBOX settings?

I was able to follow the instructions and got hardware acceleration
to activate, but I got the same screen to come up. I don't understand
what it is telling me. Could someone help me out?
Post edited May 06, 2014 by coolmanbritt
Got it to work. Had to change the shortcut like the man said above me.
However now it stutters so much to be unplayable. Is there
any fix for this.?