It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi,

In LoL2, after bringing the remains of the emperor to the statue of Belial, the statue starts walking, but it seems to be getting stuck on an invisible wall, because after waiting for about 15 minutes, it's still in the first room. I have a save just before bringing the statue to life, but reloading doesn't fix the issue.

I haven't found any mention of this issue online. Does anyone know how I could fix this?

Thanks in advance!
This question / problem has been solved by dr.schliemannimage
It should enter the narrow passage: watch this video as a reference.

Unfortunately I have no solution. Try to wander around a bit, maybe preceding the statue.
Post edited August 28, 2017 by dr.schliemann
Hey, thanks for the quick reply.

So, I looked at the video, and it seems the two torches form an invisible wall. The statue is slower in my game, and when it finally reaches the two torches, it stays stuck for a while, then turns around. I tried a bunch of things, such as pushing it, preceding it, going back into the "statue cutscene" room, leaving and coming back, and nothing changes. I even tried running the game in lowmem mode, but that doesn't help either.

Oh well, thanks anyway.
According to the video, you can trigger the cutscene of the fight with the worm entering its room, but I suppose the statue has to break the wall before this could happen. And the video commentary states that "sometimes it can take ages until it finally does it".
I decided to load my quick save and wait some more, and the statue immediately broke the wall. Seems like I should have waited for 16 minutes instead of 15.

Thanks for your help!