It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I pulled up the key mapper with Ctr F1 and for some reason when I try to bind a key it just doesn't work. I've checked directions elsewhere and am 99% confident I'm doing it right. I choose the key (e.g. 8 on the number pad, wanting to bind it to W), press Add, get the red-lettered instructions, click the other key, and nothing changes. Doesn't work with any combinations I've tried.

I can, however, delete the original bind just fine.

It''s been a couple years since I changed the key mapping in a dos game and I was able to do it fine then...though it might have been on another computer, I can't remember for sure.

Using Windows 7 64 bit.

Thanks for any help. I am pretty much a noob at the DOSBox thing.
This question / problem has been solved by dr.schliemannimage
If I understand correctly, and thinking about Lands of Lore, I suppose you want to bind the "W" key to the "8" on numpad event, meaning that pressing the "W" key you want to go forward in game.
Well, if this is correct, you should follow these steps:
1) Open the key mapper (Ctrl+F1).
2) Choose the event you want to bind to another key in the virtual keyboard and click on "Del". Now the event is not bind to any key.
[i.e. The up arrow ("key_up" event).]
3) Click on "Add" and choose the key you want to bind to the event.
[i.e. The "W" key to bind it to the "key_up" event.]
4) In the virtual keyboard, click on the key you've just chosen in step 3 and click on "Del" to unbind its default event, otherwise it is bind to two different events (its default and the one you added above).
[i.e. Click on the "W" key and click on "Del".]
5) Repeat steps 2 to 4 to change others key/event bindings.
6) Click on "Save" when done.
Thanks got it working. Not sure what I was doing wrong before.