It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi people!

So, after a lot of research, I finally figured out how to play KKND Xtreme in high resolution, working with our GOG version. Here's my steps to get it working. I have done it many times on different computers and it always works. Check it out.

1. INSTALL
Install KKND Xtreme from the GOG installer or from the Galaxy client, as you wish.

2. PATCH

Download "KKND Xtreme HighRes Changer GOG.zip" file here: (copy and paste in your adress bar)

mega.nz/#!4QERHLgR!R9m1UPrTwacDE3xFPB7f9SmeSZ6GctWhGuw40727tS0.

You must have ".Net Framework 3.5" or higher installed.
Then, do the following:
1. Unpack all files from the archive in your installed KKND Xtreme folder.
2. Use "w7ddpatcher.exe" to patch "KKNDgame.exe" (this will add registry keys for
DirectDraw compatibility for game).
3. Use "GameResolutionChangerKKNDXtreme.exe" to change game resolution to whatever you want. For example, 1024x768. DON’T RUN THE GAME YET.

3. RUN
Download “DxWnd” file here: (copy and paste in your adress bar)

sourceforge.net/projects/dxwnd/

or here:

mega.nz/#!sYEzVKrb!QJQ_RtWRqt2quk_hOE0sfWHPi4dcKGF8S7bGRPn6WfE.

You don’t need to install the app, but you will need it to run KKND Xtreme in HighRes, so you will need it always. I usually create a folder called “DxWnd” inside the KKND Xtreme install folder, so I always know where it is.
1. So, extract the archive to a new folder called DxWnd inside your KKND Xtreme install folder.
2. Run “dxwnd.exe” AS A ADMINISTRATOR (don’t know why, but the game crashes other way).
3. Go to Edit > Add.
4. In “Path:”, click […] and search for the “KKNDgame.exe” file in your install folder.
5. Check “Fullscreen only” and uncheck “Run in Window”.
6. Lastly, change the default 800 and 600 values at “Position” section for the ones you set with the HighRes Changer at step 2. For example, 1024x768.
7. Click OK and then double-click the new item in the DxWnd window.

Enjoy this great classic in all his pixels glory!

Let me know if it worked (or not) with you guys. :)
I can't seem to get it to work properly, the game launches in a small window in the top left corner

Edit: Running it in windowed mode and it looks like this
Edit 2: Ok, looks like its just the menu and cutscenes that are really small, when in-game it works fine!
Attachments:
asd.png (320 Kb)
Post edited November 24, 2016 by Fredaaay
avatar
Fredaaay: I can't seem to get it to work properly, the game launches in a small window in the top left corner

Edit: Running it in windowed mode and it looks like this
Edit 2: Ok, looks like its just the menu and cutscenes that are really small, when in-game it works fine!
Yes, the cutscenes look small, but the gameplay works. :) I'm glad it worked. Bests!
Jak się pozbyć kursora z tego ekranu?
Attachments:
Not working at mines windows 10 ???
Well, mine worked really well after step 2, ignoring step 3 totally. Actually it was even better, for running via DxWnd gives a screen-tearing effect, while running kkndgame.exe after patching has a built-in v-sync. lol
does not work properly, small window in cut scenes and in the gameplay. ""GameResolutionChangerKKNDXtreme.exe" does not want to save my resolution settings even after pressing APPLY. When I start it againg, its set on 640x480 as custom.
avatar
helganin: Jak się pozbyć kursora z tego ekranu?
I have the same issues. No matter if i use DxWnd or not. Iam on Win 10 and really want to play the game in full HD.
Leave out "3. Use "GameResolutionChangerKKNDXtreme.exe" to change game resolution to whatever you want. For example, 1024x768" from the instructions. This makes the game run in fullscreen because DxWnd streches the 640x480 window to the resolution entered in DxWnd.

But how to launch the game with DxWnd from Galaxy in order to have game time tracking?
It worked for me, following the exact same steps as OP described.
Leaving out the 3rd step was no good for me, on Win10.

Nevertheless, I had to play around with it for a while. At first, on DxWnd I could not play with res 1920x1080, so I started with 4:3 ratio (1024x800 I think was the first try) and worked my way up from there, changing the resolution on GameResolutionChangerKKNDXtreme.exe and then on DxWnd. It works flawlessly in FullHD now.

Keep in mind that only the gameplay is FullHD, the rest is a very small screen on the top left of my screen, but that's good enough, gameplay on high res looks awesome.

I attached some images.
Thanks a lot @lucasflach !
Attachments:
kkndmenu.png (334 Kb)
Post edited June 26, 2019 by SebaCueto
Ingame Img
Attachments:
Post edited June 29, 2019 by SebaCueto
I can´t make it to run 100%

When i put it on 1920x1080 and enter the game its all good, but them when i get to the actual map is kind like the screen is not full, there a vertical bar on the left and right of the corners and when i right click the screen start´s to shake and i cant click the building, map, money buttons etc...

Anyone got that?
Ok, so i tried that for myself and finally managed to get it working aswell.

I did follow all the Steps, first i used the w7ddpatcher on the KKND.exe, which did start the game, not sure if that is supposed to happen, but i just closed it again and continued. Next i used the GameResolutionChangerKKNDXtreme to set my resolution to 1920X1080 and hit apply which gave me a "succesful"-window. Last i did start DxWnd as admin and changed the resolution to 1920X1080 aswell, demarked "windowed" and marked "fullscreen only" BUT i had also
switch on the right from "X,Y coordiantes" to "Desktop Work Area", to have an actual fullscreen.

Ingame the Main menu is as already told still 640x480 on the top left corner, but as soon as i start a campaign i have to click onetime with my right mouse-button and the screen goes 1920x1080 and i can play totally fine! For a note: After that you should not use your right mouse button again, as for me it could somehwhat break the ingame screen.

Thank you very much lucasflach! This is the only working solution i could find anywhere these days.

EDIT: Ok it seems 1920x1080 is not working, as i found out that i always have a border and can't use the build menu on the right, so i changed the resolution to 1600x900 on both the GameResolutionChangerKKNDXtreme and DxWnd and it does work without any problem now, can even use my right mouse button again.

Greetings
Deadworker
Post edited February 03, 2020 by Deadworker