It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I just bought and installed the collection, but every time I try to launch it I get a blank white screen for a second or two followed by two error messages:

DirectDraw Failed, display card does not support this resolution; then: KSS initdirectdraw failed closing application.

I have tried changing compatibility modes, installing with or without Galaxy, and running as Admin, but nothing helps. I'd welcome any simple ideas. I'm nowhere close to a programming expert, so please feel free to dumb down any solution ideas. My CPU runs Windows 10 and can handle plenty of games far more demanding than these great 8/16-bit relics. GOG support says it could be weeks due to their support backlog, so I'd appreciate any insight those of you who know a lot more than me can offer. Otherwise, I'd just as soon forget it and request a refund. Thanks for reading.
This question / problem has been solved by neumi5694image
Basically you need to replace youd direct draw dll.

There is one that caused some old games with hardware acceleration to run properly on modern systems.
I couldn't find a direct link where I was sure it's the right one, but it is also part of dgVoodoo2.

Try to download that and put the contianed ddraw.dll in your game directory.

btw, don't let the warnings of google or firefox or your antivirus software scare you. dgVoodoo2 always gets false positives, something like "it might change your system in unwanted ways" ... well, that's the whole idea of emulating graphic hardware and overriding dll commands. The dll accepts old commands, passes them to a emulator or swaps them for modern commands and does the same when the answets come back from the system.
The warning is absolutely right, the dlls are just not dangerous.
Post edited September 29, 2020 by neumi5694
Thank you for responding, neumi5694. Your point is right on (I've marked your post as the solution so the question part of this topic would close) as I heard from GOG support far sooner then I expected and they guided me to a similar idea with a few files. There were 3 .dll files I needed and as soon as they were there it booted right up. I am greatly appreciative of the community on here keeping an eye out for each other, and I want to credit GOG support for being very helpful (and quick!) on this. Good gaming to all.
Post edited September 30, 2020 by gamingrn
avatar
gamingrn:
I'm glad to hear you can play now.
Could you also please post support's solution or what dll files they guided you to, maybe also with a link?
avatar
gamingrn:
avatar
neumi5694: I'm glad to hear you can play now.
Could you also please post support's solution or what dll files they guided you to, maybe also with a link?
Yes, I can give the answer, sorry I didn't think to do so earlier. Unfortunately, I don't have the link they gave me (dumb me deleted the message string after the problem was solved), but it was to dropbox. I think the files came from whatever DgVoodooOLD is. Looking at the folder on my computer, they are:

D3D8.dll
D3DImm.dll
DDraw.dll

I just had to download these 3 files and copy them into the Konami Collection folder. Once I did, everything worked just as it was supposed to with no need for any compatibility settings or otherwise.