It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey guys
here is my problem : Yesterday morning, the game was launching correctly. I played some time and then stopped. But during the afternoon, i lost my connection to internet, and then changed temporarily my connection type (i'm normally in ethernet cabled connection, but changed to wi-fi key type for a few hours) and now my game isn't launching.
It tries to initialize and i can even see the icon appearing for less than 1s, and then disappearing, as if the game was launched and instantly closed.
I need help cause i trid every idea crossed my mind : launching as admin, compatibility with win 8, win 7, vista and even XP, and then tried tto downgrade the game's version. This morning, i even tried to reinstall the game. But it still doesn't work, always the same problem.
If anyone has an idea, let me know.
Post edited January 24, 2019 by Lucatraus