It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I am unable to get the game to start, I press play and nothing happens. I've tried running it as admin, as Windows 7/XP (because my PC won't allow me to run it as windows 2000) in the supersmall resolution that is bound to fuck up my desktop whenever I play the game, and I've gone through the gog support page, nuthing works.
If there is a simple solution, feel free to share it because so far I am just pissed at gog.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Could you specify which game of the series gives you trouble?

Cheers, Alex
I just finished Armored Princess and last month King Bounty: The Legend, so yes i can run them.

Windows 10, no compatibility mode but run as administrator
I am also not able to get this game to start. Have tried teh 'run as admin' mentioned above, but with no success.
Granted the req's may not be equivalent but my system runs starpoint gemini 2 with no issue. My system has an Nvidia quadro 2000 (ex work CAD workstation) so I would have thought it should be ok (but I freely admit to being no kind of expert).
Seems to work if I run it as XP SP3 compatible.