It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The game was downloaded via EPIC GAMES. The game is beautiful, everything worked well, there were absolutely no problems. Soon I got bored with the game, but I decided to download it again, after the second download there was some kind of failure. Doesn't move to new islands. Not at all. I reinstalled the game, I also replayed from 1 island, starting with a new game, in the hope that the game bug would be fixed by itself. I also tried to go from the last island where I stopped. Didn't help either. If we consider my work outside the game: I thought that a possible problem is in outdated drivers, I installed new ones. Did not help. DirectX also downloaded the latest version of Visual C ++, this also did not help me in solving the problem. Just in case, I checked my computer for viruses, everything is clean.