It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I am totally confused how to mantle a horse. I am approaching a horse named Pebbles and no matter what I do I cannot mount this horse. I approach and press the "horse" key and absolutely nothing happens. How do I mount a horse in this game? It looks like I will have to stop playing this game until there is a resolution.

EDIT: Yep, looks like this a major bug and I am unable to complete The Hunt Begins mission. And since the Vengeance main quest cannot be completed until the The Hunt Begins has been completed, I cannot proceed with this game. I am now forced to play side quests or quit playing. I now realize that the more I play this game, the buggier it seems. There have been numerous patches and it is really starting to look like this game will never work properly. I hate to give up on it but it is looking like I will be forced to. I have never seen a game with so many bugs.
Post edited January 13, 2019 by user deleted
have you tried to verify/repair? sometimes it just needs a little clean up to work
I have tried everything. I tried verify/repair too. Nothing works. I have even gone back to a previous save and played it up to the part where I need to mount Pebbles and there is still no prompt to mount him. He also does not respond when I whistle. I cannot mount this horse needed to continue the main quest so I had to give up. I believe I will have no choice but to uninstall this game. Kingdom Come never should have been released in this condition. It is still clearly in the alpha or beta phase.
Post edited January 18, 2019 by user deleted
yes, try the re-installation next, then verify again
I believe I just fixed this issue but not by simply reinstalling and verifying the game again. I'll post what I did to fix it in another thread.
Post edited January 20, 2019 by user deleted