It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have completed the 'Save your parents" quest. The cut scene starts to play and shows fire scene - can go no further. Tried quitting and restarting. Same result. Tried uninstalling and reinstalling the game. Same result.

Very frustrating. Don't want to start all over from beginning. First two quests (fleeing on foot and then on horse) are just too tough.

Thanks for reading and for any help or suggestion.

Also, is there any way to get help from GOG on this?
Restarted the game and played through to complete the Save your Parents quest. Then, the cut scene where Hal is taken to the miller's place and the opening credits run. Then back to "Save Your Parents" and the blurry fire and embers scene which will run forever if I let it. Cannot get past that.

Anyone else encounter this? Any help?

Thanks for reading.