It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

H3RB3RTW3ST: I've done that. It checks itself back. That's why I'm so puzzled. I have admin privileges too. I'm just baffled.
Zogundar: This comes a tad late almost 2 1/2 years later, but I was having the same issue and after a great deal of searching discovered the problem.

There's a registry entry that's responsible for this.

(As always, beware editing the registry, you can destroy Windows, etc.)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers\C:\(Install Directory)\(Game Directory)\KODP.exe


I deleted everything except "RUNASADMIN." After this, I was able to make changes to the Compatibility section and make them stick.

Combined with jerfa's post in this thread I'm now able to play the game, windowed, without having to manually change the screen resolution afterward.
Never too late for a fix.

I followed everything in this thread except for the Python script on WinXP.

Good news, it works after getting the registry key modified.
Bad news, the window looks like the attached pic and I can't resize the window because the game itself won't follow along.
untitled.png (429 Kb)
Post edited May 06, 2015 by Projectsonic
Projectsonic: I followed everything in this thread except for the Python script on WinXP.
Well guess what you need to do! :)

1. Install Python
2. Install PyWin extension
3. Run jerfa's script

If you do this it should appear in a normal looking window.
This may be a necro, but I can't find a good solution anywhere, and I know I had done something that more or less worked for me in the past. So I messed around and determined that it was this:

1. Add the -w extension to the Shortcut "Target"
2. Switch to Compatibility tab, change to compatibility mode: Windows 98/Me
3. Launch it, after launch (and it changes the resolution to 640x480), Alt+Tab and you'll be able to right click inside the taskbar, select "Show the Desktop"
4. Right click on the desktop, change the resolution to something higher, per your taste. Then you should be able to play it windowed and sized as you like. If you try to run it under a very high res, obviously, you'll be playing in a postage stamp. I usually run it in 1280x768 or something on a 27", and the size of the game is good, and I can still use my web browser in a somewhat limited capacity, but still.

Just pretend like it's 2004 again. It's nostalgic.