It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've installed this game on my husband's laptop, specs:

Acer Aspire V3 - 772G
Windows 10 - (upgrade - fully updated)
Intel Core i7-4702MQ 2.2GHz (Turbo boost to 3.2GHz)
NVidia GeForce GT 750M (4Gb) (fully updated using GeForce Experience)
16Gb DDR3 L memory

Every time we start the game we get the message "nVidia PhysX is not installed! Do you want to install it now?" On selecting 'Yes' we receive the error "Cannot execute nVidia PhysX installer. Probably this is because you don't have administrator rights. Try installing it manually.' His user account is an administrator account, but even right-clicking the game shortcut (or even the .exe directly) and selecting 'run as administrator' causes the same error.

Before anyone asks, yes, we've restarted the laptop after installing the game to see if some updates needed a reset - no change! (IT support background here!) ;-)

I've Googled and found a lot of people who bought this game on Steam have experienced the same issue and have had to tweak scripts with values from the registry or manually run installers. Unfortunately, I can't seem to locate any of the installers or scripts in the game folder. Where would the GOG installer put game related files if not in the game install folder? In any event, PhysX is fully up to date so doesn't need to be re-installed.

Also, whilst I'm on the subject of Steam, can anyone explain why a GOG installation contains the files 'Steam_api.dll' and 'SteamAPIUpdater.dll'? (screenshot attached).

Any help would be gratefully received. Thanks. :-)
No posts in this topic were marked as the solution yet. If you can help, add your reply
I'm not familiar with Windows 10, but I'd try this.

Uninstall the game (pain in the butt, I know!). Reinstall the game from the installer (I hope you didn't use Galaxy :( ) BUT before you run the installer right click on it. Run it as Admin.

Also, I know I've had problems before with certain installers that had another check box under one of the tabs, that says something like "Block from running / executing for security reasons" or something like that. Allow it / unblock it (if you see something to that effect - if not I'm not sure).

If not, I hope someone can help you out and soon!

I had the exact same problem. Verified Nvidia drivers were up to date as well. Basically I started by googling the same problem you did. I did find a post on the Neocore forums posted by a Neocore employee that lead me to a solution.

I use GOG Galaxy so my installation folder looks something like this.

...\GOG Galaxy\King Arthur Collection\
*Note: Your will likely differ slightly based on GOG Galaxy setup or using the GOG standalone installer.

The paths you'll be looking for for the redistributed files identified in the post are:

...\GOG Galaxy\King Arthur Collection\__redist\DirectX\DXSETUP.exe
...\GOG Galaxy\King Arthur Collection\__redist\MSVC2008\vcredist_x86.exe *Note this file isn't named the same as the one in post, but I have reason enough to believe its the one.

I ran both of those files as administrator and restarted my computer; however, it didn't fix the problem.

So next I looked for the PhysX redistributable file "PhysX_9.09.0814_SystemSoftware.exe" as highlighted in the post, I couldn't find it anywhere in the GOG installation. At this point I figured I'd download it and install it manually.

I saved the file to the ...\GOG Galaxy\King Arthur Collection\__redist path and ran it as administrator. After that I was able to successfully launch the game without a computer restart.

I hope this helps. I'm sorry for not providing hyperlinks apparently I don't have permission to do that.
Post edited October 20, 2015 by DeepSpace79
DeepSpace79: I hope this helps. I'm sorry for not providing hyperlinks apparently I don't have permission to do that.
You need 10 or so reputation to post hyperlinks I belive. It's an antispam feature. Anyway, here's like to Nvidia's PhysX dowload page.

Version 9.15.0428 dated 2015.05.21 seems to be latest.

Oh and do use reply function (shows when you hover mouse cursor over post you want to reply to) when replying to someone so they get notified of the reply.
Post edited October 21, 2015 by Petrell
LynetteC: Also, whilst I'm on the subject of Steam, can anyone explain why a GOG installation contains the files 'Steam_api.dll' and 'SteamAPIUpdater.dll'? (screenshot attached).
More than likely they're dummy dll files present to allow game to run without steam and/or stopping it from throwing steam related errors. I'm pretty sure it's not the only game on GOG to have such leftovers nor the last considering number of games that have gone thru full steamworks integration. Some of them are later removed if better solution is found.
LynetteC: ...
Mine required a repair of C++ redistributable to install properly. Perhaps reinstall that and try the PhysX install again?
I had the same problem. There were some hiccups regarding physx during install (with the standalone installer), but I could run it anyway. Then Galaxy updated the game, a warning saying "you are uninstalling Physx" was displayed, and it didn't work anymore.

I solved the problem by downloading a physx installer from the Nvidia website, and running it. Works fine since then.
On my windows 10 I've solved the problem running the game as administrator.
Doesn't work:
I put admin compatibility, DL PhysX and run it: it says I already have it up to date.
But the game says I don't have PhysX installed, even I run it as admin.
Maybe the game wants to install it but PhysX doesn't want
for in fact it is already installed and it stops the launch of the game?

EDIT: Okay, I've desinstalled the game, reinstalled it (9GB download..), restart computer, and that's good now.
Post edited April 16, 2016 by ERISS
Had similar problems, reporting my experience in Windows 10 in case this helps anyone else.

1. Installed the game via Galaxy, many other games already installed.

2. Nvidia PhysX installer ran, but reported "more recent version already installed". Only option was to cancel, and that "canceled" the game install. But I already had a desktop shortcut and all the installed files were left alone.

3. Trying running the game (Windows 10 64bit) gave the "nVidia PhysX not installed, install now..." dialog. Saying "yes" failed with the "you need to be administrator" error.

4. So I ran the game as admin (right click shortcut, run as admin) and it runs fine. No PhysX message, just runs great.

5. But if I don't run as admin, I still get the PhysX message.

So I set the shortcut to always run as admin, and that should work for now:
* right click on shortcut, select properties
* Click [Advanced] button
* Make sure "[ ] Run as Administrator" checkbox is checked
* Click OK to close the Advanced and the Properties dialogs, all set!