It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I like my mods. All i want is 1.6.1 but I can't download it anywhere. Is there any way to get the older versions? Gog Galaxy isn't compatible for Linux sadly so I can't use their rollback feature.
avatar
Davidc9998: I like my mods. All i want is 1.6.1 but I can't download it anywhere. Is there any way to get the older versions? Gog Galaxy isn't compatible for Linux sadly so I can't use their rollback feature.
Just want to bump this, though this forum is basically dead. I seem to recall there being a feature request to add a drop-down for older versions to the download page, but I can't find it now. I want to do a Realism Overhaul install that has instructions for 1.8.1, but I've only been saving the installers locally since 1.9.