It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Can someone explain what is going on? I had this issue with the steam version too.

I have decals off , i don't get it?
unknown.png (208 Kb)
Yeah, I get that sometimes too. Decals off + vsync + max 60 fps limited in GPU driver and it never seems to crash anymore and things are stable now with no wierd physics quirks.

My suggestion to stop the GPU artifacting would be to use a GPU driver of the vintage of the game. So pick one 2010 (game release) to 2011.
Actually, looks like there may be some hope for this "large building artifacting" issue from steam forums. Solution appears to disable the "bokeh filter" in graphics settings.

See here for more info: