It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just thought how good would be to play Jazz Jackrabbit 1 because I enjoyed the action platformer game when I was kid.
I completed the first episode on Hard difficulty mode and after the cutscene, I can't type anything on High Score screen.
I installed the newest GOG version of Jazz 1 and I believed that nasty bug isn't occour on the end of each episodes.
What should I do if that issue happens again?
Did you guys ecperience this bug?
I remember that bug in the original and CD version of Jazz1 didn't appear.
Could this bug have something to do with the latest GoG version?
If I would replace the regular DosBox emulator with it's newer iteration, that problem could be solved?
As I played the first Jazz Jackrabbit game on another PC, the issue doesn't occour.
I think it's machine-specific issue, I mean it allows you to enter any letter and number within the score list
Feel free to delete this post as I don't think there is a universal solution to this problem.
After a year and a half, I started to play again the GoG version of the game Jazz Jackrabbit 1, via GoG Galaxy, and the game allows you to enter the name in the High Score list after completing the episodes.
So I guess the GoG Galaxy client is required for the legal playing.

If I had tried this sooner, maybe I wouldn't have to made this topic.