It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


i tried to run 1.13 mod under modern Linux & wine (wine version-7.18), but got error like that:

Initializing Virtual File System failed

sgp.cpp - that file has been mentioned

but Jagged Alliance 2 Stracciatella and Ja2 original (from gog) are working excellent. So basically i am able to play JA2 in "modern way" but only with Stracciatella solution.

anyone fixed this "VFS" error?
No posts in this topic were marked as the solution yet. If you can help, add your reply
braf_krk: [...] anyone fixed this "VFS" error?
Apparently someone did.
braf_krk: [...] anyone fixed this "VFS" error?
dr.schliemann: Apparently someone did.
Thanks, i tried this, but issue is still the same
btw this solution is very old
ok, found it.

so basically i have my own wine wrapper which is little changing cwd. I used that wrapper for around 30 games in Linux and never had any problem.

So we need to know that this game is extremely sensitive for cwd - we can use only LOCAL path

for example -

this will work:
cd ~/.wine/drive_c/JA2 && wine ./ja2.exe

but this may not work:
wine ~/.wine/drive_c/JA2/ja2.exe

and also this may not work:
cd ~/.wine && ./drive_c/JA2/ja2.exe

basically if we will have any manipulations with cwd/pwd, then this game can crash.

so topic is solved
Post edited September 26, 2022 by braf_krk