It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Greetings, my students!

OK, now to the business at hand. Recently my PC R.I.P.'d. Now, I plan to build a new one by the end of this year, however, since I needed to get a replacement as fast as possible for the time being, I had to dust off my old notebook which only has its APU unit; there's no dedicated graphics card. The APU I'm talking about is an A6-3410MX. Jade Empire, like many other 1999-2008 games, has a bad reputation when it comes to AMD support, especially if we're talking about APUs. Nobody seems to care about them, Intel is worse, but that's beside the point. The point is when in game, I get 20-22 FPS 99% of the time. Furthermore, when I stand in a heavily post-processed area where there's a lot of post-processing effects such as bloom or fog and smoke, aka alpha effects that eat your FPS unless you have an old graphics card of that era that was somewhat designed to handle physics of bygone age, and since I don't, I get 15~18 FPS. The game itself, plays AND feels as if it was running at stable 30 FPS but for whatever reason shows 20~22 FPS. And it even doesn't matter whether I use Fraps, CAM, or that Afterburner or whatever its name is. Same goes when I'm not using any monitoring software. Same old 20~22 FPS (My monitor has a feature which shows 'in-game' framerate, basically the monitor can individually monitor every fullscreen program and tell me what resolution and framerate that particular program is using.) It is fair to mention that if you have one of the newest graphics cards they tend to drop FPS in some areas as well, not all, but still. And so, I tried every possible combination in JadeEmpire.ini to remedy the situation. Alas, nothing really helped. Even the obvious 'ForceShader1' is completely useless. Oh yes, also, other games that I have installed on this piece of crap of a PC work perfectly fine as they are. They don't drop FPS unless the game itself is quite demanding then it is expected. So, it's only Jade Empire. I'm guessing this is what I think it is, APU issue. Ancient games weren't designed with APU support in mind. I should probably add that the game doesn't even care what resolution I use. 640x480 or 1920x1080, it doesn't care. The game still shows 20~22 FPS. So, it is definitely not GPU bottleneck, more likely a CPU issue, or in this case, an APU issue.

Some of my friends and acquaintances had problems with this game while they were using GTX 500s/600s and even GTX 900s. It's always random. Another thing I probably need to mention is that I'm using Win10. Never had any framerate issues on XP SP3 or Win7. Granted, Win7 was a pain in the ass to deal with if you wanted to play old games, hello KOTOR 1&2 pre-2015 patch.

Before you start proposing to reboot my system 7 trillion times or apply stutter fix, don't - I know about those tricks, known for almost a decade now. Never had any problems with the stutter or jittery framerate as if the game was running at 15FPS. Plus I applied stutter fix and it did nothing for me. And yes, I did update that redistributable, the shit keeps updating itself... finally something useful out of Windows 10 with its autonomous/shoved down your throat updates. Windowed Mode also didn't help. Actually, come to think of it, it made things worse. If I had 20~22 FPS before Windowed, after I applied Windowed, the game ran at 15, ceaselessly.

So, having said all that, I ask you, fellow Students or Jade Masters... depends on your skill - is there anything else you can advise me to do? Maybe there's something I can do via Windows Registry settings. I doubt that BIOS will be much of help. I mean we're talking about barebones notebook from 2011 and APU at that. Oh yes, for those who would advise updating AMD Catalyst, it doesn't work anymore. It seems I can't bypass 15th edition of the program. It's being blocked by Windows 10 which sees my hardware and doesn't allow to update since it thinks it won't do much help... Windows never was a bright one. I remember Windows 7 allowed me to update to 16th edition of the Catalyst, I think it was 16.20.something.something.beta. However, when I try to install that beta version or even the newest on Win10 it just gives me an installation error with a go-fuck-yourself sandwich as a compliment from the Chef. Or should I just deal with it and wait till I get new a PC?

The End.

EDIT: Stutter fix did nothing mainly because the build of the game already has it installed.

EDIT v2: I think I got it. I forgot that this game has problems allowing its .exe file to be modified. At least, I can't modify .exe on Win10. Win7 worked just fine. Also, I remembered that Mirillis Action! doesn't work here, that's another hint that something wasn't right. Plus the notorious Sync issue this game has. When I launched the game along with CAM (monitoring software) and enabled it, the FPS droped to 20-22. However, right after I disabled the HUD for CAM while running Jade Empire the framerate got back where it supposed to be - 30/60, aka fluid movement and stuff. It seems the game is best played at 1024x768 or slightly glitched 1920x1080.
Post edited October 04, 2018 by Phlegios
No posts in this topic were marked as the solution yet. If you can help, add your reply
As you allready said...much has changed over the last 10 years and it's even worse then you described Pc's use protcolls the old games don't support, they miss hardware and supporting software the old games need and so on.

They adress some of the problems here

but i did'nt tested it myself

Aside from this there're other fanmade fixes, you can try a emulator and sometimes it's enough to backroll you're drivers and stuff like this..but chance are..even if you get it running everything else will stop working correctly.