It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Anyone else try running this in Windows 10? It crashes constantly on me. Not just to the desktop either, my whole PC freezes up and I have to restart the computer to fix it.

My PC specs:
AMD FX-8320E 3.2ghz eight-core processor
16gb RAM
2gb Radeon R7 265 GPU
Windows 10 Pro 64-bit

Is there anything I can do to make the game play more stable?

To go into more detail, I can play the game a short amount of time, maybe an hour or two, and it will randomly crash with no rhyme or reason. Nothing in particular seems to trigger it.

I've gotten to the second city with the dam, but I've gotten a bit frustrated with the crashes at this point. I don't want to play any more unless I can get this solved.
Post edited December 23, 2017 by iofhua
I'm getting the same issue on Windows 7. Can't seem to find any fixes for ingame crashes anywhere apart from this

http*//jadeempire*wikia*com/wiki/Crash_Fix (CHANGE * FOR .)

which hasn't worked for me.
The game is crashing to me, the first time i enter the Southern Forest and the 3 ghosts come, when the one with the white mask and black robe shows up it crash's.