It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

After playing for 4 hours, with saves and reloads. The game now doesn't lauch anymore.

The game was installed and launched using GOG Galaxy 2.

I don't know what's different.

Instead of beggining, the screen goes all black except for a white box on the top left corner.
Sometimes I can't even see the others windows, so I have to disconnect and reconnect to regain control of the computer.

I have no Idea what happened between last time it worked and the first time it didn't launch.

I'm under W10 using a Lenovo Ideacentre AIO Y910 27ISH (if this is any help).

Did anyone run into a similar problem ?
Well I managed to fix it.

After disabling cloud saves, deleting my saves, removing fullscreen optimization and downgrading to an earlier version.
The game launched again after I updated my Video Card pilots.

I still don't know why it worked fine first and then couldn't even load.

But hey, if someone else see only the black screen with the little white box on the top left and it either crash or nothing happens, the problem could be linked to the video card settings or drivers...