It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just cannot get this game working at all. I have tried all the tips people have said to try but the game just refuses to boot. I keep getting Z-buffer failed error on boot.

#1 - I have tried download the dgvoodoo program but I'm unsure as to how to use it.
#2 - I have tried copying and pasting the following dll's: D3D8.dll, D3DImm.dll, DDraw.dll into the games root folder
#3 - I have tried copying the ATIumdag.dll into the games root folder

Nothing seems to work for me at all.

Specs are:

AMD FX 8350 @ 4GHz
Radeon RX 480 ROG Strix
I can get the game to launch however it is unplayable. Attached is the dgVoodoo settings I use. The game seems to load the menu up just fine and the demo in the background runs without problem. However, if I start a new game it becomes completely unresponsive and starts to lag to the point of audio skipping.

Without dgVoodoo the game does not even launch, reporting a graphics initialization error (something about the Z-Buffer).