It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm at the point of giving up on this game as gog's version seems completely broken at this point.
I've tried just about anyting from dgVoodoo 2 to all that is said on PCGamingWiki but nothing works.

The most luck I had was pulling out my orignal CD-rom copy of the game but with dgVoodoo I have a lot of graphical glitches.

Will maybe try contacting support, but since they already given up Windows 10 support it's doubtful they'll provide anything useful.
No posts in this topic were marked as the solution yet. If you can help, add your reply
If you didn't try that yet, try moving the game directly into C: drive (so the game path is C:\Incoming). For some strange reason, that solves a lot of issues.
Yes, this does work, but there are still some steps left to do, if you want to run the game.

I did the following and now the game works:

1.) as Vykrom0d mentioned, move (or when installing the game) select C: drive, so that the Incoming folder will be on location C:\Incoming.

2.) because I have an AMD APU with the integrated Radeon, it crashes instantly after opening.
I"ve got an Z-Buffer error message.

Than I tried to use the solution from GOG, that says download atiumdag.dll and put in into the game's folder.

I did that, but sadly, I still got the Z-Buffer error message... so that didn't help. All the time I tried to run the game as an administrator.

3.) I was desperate and was looking for a solution, how to run this game on modern hardware and than found a post on Steam Community Forums, where they wrote, that one should try dgVoodoo 2.

I tried it, all setting set to default except the graphics setting to emulate an ATI Radeon 8500 Videocard, but this didn't help much, again black screen, loading (blue circle) cursor and crash back to desktop with an AMD graphics driver error.

Then I somehow found a sentence, that wrote, that if you still have problems with crashing or not loading, try to disable mipmapping textures (there is this option in dgVoodoo, where you need to add a checkmark).

And, I couldn't believe my eyes (and ears), the game started! (●'◡'●)

My PC configuration:
AMD Ryzen 5600G with Radeon Vega 7
32 GB RAM DDR4 3200
Windows 10 Home 64-bit version 21H2 (build 19044.1706).

- - - - - -


In that guide on Steam Community Forums, there is also a solution to play the game at 60 fps*, but there are more steps involved.

*You can also try, to disable/enable VSync option in dgVoodoo. The game menus works between 17 and 60 frames per secons/fps (or whatever you graphic setting are) and the game does mostly works with 30 fps.

Oh and one more thing: the game is unplayable with mouse. Use a joystick/gamepad or keyboard. Trust me.

- - - - - -

And here are my dgVoodoo 2 settings and some screenshots from the game.

Look at attached screenshots.

- - - - - -

Now I just need to find a way, that the game doesn't crash/freeze, when you select the EXIT option. :)
incoming1.jpg (239 Kb)
incoming2.jpg (356 Kb)
incoming3.jpg (343 Kb)
Post edited May 15, 2022 by OPlays22
The game runs on windows Xp with g92 based nvidia cards or older and driver version 258.96 or older , game also runs with dgvoodoo2 glide wrapper on windows 7 both 64 and 32 bit along with Vista in both versions. Ive tried game on windows 10 with no luck
Thanks for the info all but I already caved in shortly after I made this thread and bought the Zoom Platform version which worked right away and also has the expansion pack.
Works for me with DgVoodoo2's MS files and the Incoming commandline -screenmode -8mb
Strijkbout: Thanks for the info all but I already caved in shortly after I made this thread and bought the Zoom Platform version which worked right away and also has the expansion pack.
Wow thanks for your post. I just got the Incoming Trilogy from Zoom Platform (Which I had never heard of until your post) and It works flawlessly on Windows 10!