It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
version française

-----

Hello fellow Debian users, Ubuntu lovers and Mint freaks!

Here you’ll find scripts allowing you to build a .deb package from your Windows installer for Impossible Creatures. You can install it through DPKG and remove it through any APT front-end (apt-get, aptitude, synaptic, etc.).

Download links and usage instructions can be found on the following page:
Impossible Creatures

I hope you’ll enjoy the comfort provided by these scripts as much as I enjoy writing and tweaking them ;)

-----

Here you go for more supported games!
avatar
vv221: version française

-----

Hello fellow Debian users, Ubuntu lovers and Mint freaks!

Here you’ll find scripts allowing you to build a .deb package from your Windows installer for Impossible Creatures. You can install it through DPKG and remove it through any APT front-end (apt-get, aptitude, synaptic, etc.).

Download links and usage instructions can be found on the following page:
Impossible Creatures

I hope you’ll enjoy the comfort provided by these scripts as much as I enjoy writing and tweaking them ;)

-----

Here you go for more supported games!
Hi, thanks for that was looking for a way to get Settlers 2 working on Linux for some time now. Always had the issue that it didn't install properly under Wine.
Post edited December 10, 2015 by Matruchus
avatar
Matruchus: (…)
I understand the script for The Settlers 2 worked well for you? What distribution are you using?
I’m testing most of the scripts on Debian only, so it’s always nice to have a confirmation that they work well on other Debian-based distributions ;)
avatar
Matruchus: (…)
avatar
vv221: I understand the script for The Settlers 2 worked well for you? What distribution are you using?
I’m testing most of the scripts on Debian only, so it’s always nice to have a confirmation that they work well on other Debian-based distributions ;)
Yes, I managed to install it on Linux Mint 17.2 and the game runs perfectly. Somehow couldn't get to install the deb package manually but graphical install worked so that's that. The only problem is how to get it to extend to full screen or normal size since its just a small box in the middle of the screen.
Post edited December 10, 2015 by Matruchus
avatar
Matruchus: Somehow couldn't get to install the deb package manually but graphical install worked so that's that.
The trick is that you need to run both commands given by the script in order to get the game installed. The first one (dpkg -i …) might end up in an error, but it is normal and will be fixed by the second command (apt-get install -f).
avatar
Matruchus: The only problem is how to get it to extend to full screen or normal size since its just a small box in the middle of the screen.
Just try Alt+Enter ;)
The same keys will allow you to go back to windowed mode.

-----

Anyway, that’s great to learn that in runs as expected on Linux Mint too!
Post edited December 10, 2015 by vv221
avatar
Matruchus: Somehow couldn't get to install the deb package manually but graphical install worked so that's that.
avatar
vv221: The trick is that you need to run both commands given by the script in order to get the game installed. The first one (dpkg -i …) might end up in an error, but it is normal and will be fixed by the second command (apt-get install -f).
avatar
Matruchus: The only problem is how to get it to extend to full screen or normal size since its just a small box in the middle of the screen.
avatar
vv221: Just try Alt+Enter ;)
The same keys will allow you to go back to windowed mode.

-----

Anyway, that’s great to learn that in runs as expected on Linux Mint too!
Thx, worked perfectly. Now I feel really dumb :)

One question though, can the script be adapted for the german version of Settlers? For this: setup_settlers2_gold_german_2.1.0.17.exe
avatar
Matruchus: One question though, can the script be adapted for the german version of Settlers? For this: setup_settlers2_gold_german_2.1.0.17.exe
I’m going to work on it right now, I’ll send you a message via GOG chat once it’s done ;)
avatar
Matruchus: One question though, can the script be adapted for the german version of Settlers? For this: setup_settlers2_gold_german_2.1.0.17.exe
avatar
vv221: I’m going to work on it right now, I’ll send you a message via GOG chat once it’s done ;)
Ok, thanks :)