It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Imperial Glory runs like a dream on my desktop. Considering the modest requirements, I figured I might as well try to install it on my netbook (Acer Aspire One D250), but alas! The game gives the following error: "The application can't be initialized".
The Intel integrated graphics card is no doubt the culprit, although I am able to play Giants: Citizen Kabuto, Sacrifice, Unreal Tournament 2004 (all excellent games!), and even Star Wars: Republic Commando on this handy little machine!
The Eidos support site claims that the problem with integrated graphics cards was fixed with the 1.1 patch:
As far as I know, the version of the game is already patched to version 1.1. So am I missing something or should I just stick to playing the game on my desktop PC? Thanks in advance!
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hey, for starters I would try to set it to windows xp compatibility mode if your using vista on your netbook.
Next download and try this 3d analyze program on your netbook
The download link is the little floppie image above the text.
The game requires tnl and intel graphics cards do not support this, the patch should of fixed it but the list of intergrated graphics it fixed it for seems to be fairly old, probably the hardware out at the time. If you have a new intergrated chip which you would with a netbook the fix may not work with that.
If those solutions do not work could you find out what resolution you are able to run your netbook at and what intergrated graphics card you have?
Thanks for the reply.
The graphics card is an Intel GMA 950 (945 chipset). Hardware TnL is not supported, but the patch should have (supposedly) fixed it. Supported resolutions for my netbook are either 800 x 600 or 1024 x 600 pixels (I can force it to use other resolutions, but it's no go). I'm using XP, standard Atom 1.6 GHz processor, 1 GB RAM.
I have seen that other people continued to have problems regardless of the 1.1 patch. So I guess there's little that can be done with getting the game operational on at least some types of netbooks.
Ah well, I can still pit the "frogs" against the "lobsters" on my desktop! ;)
Did you try the 3d analyze program I linked? It emulates TnL and has got other games that required TnL to run on that same Intel GMA 950 chipset. If you have and the resolution isn't the problem I'm not sure what it could be.
As your using XP you could always try changing the sound hardware acceleration just incase.
Sorry for not getting back sooner.
The 3D Analyze program did not work (I tried TnL emulation, forcing software mode, and so forth). Changing audio acceleration did not affect anything, either. I tried updating DirectX, but I already have the latest version.
Anyway, thanks for the help.
I found the solution. Turns out it was simpler than I thought. The game gives the aforementioned error because it tries to run the game at a default screen resolution of 1024 x 768. Most netbooks, like mine, have a widescreen resolution of 1024 x 600.
To solve the problem, I went into the game's root folder and opened the file using Wordpad. Near the top of the file is the line:
I changed TRUE to false. The following two lines contain the resolution settings. I changed these to 640 x 480. The game could then be launched. I went into options, changed the resolution to 800 x 600. I then quit the game and re-edited the file to change .FULLSCREEN back to TRUE.
The game apparently does not support widescreen, but playing 800 x 600 is not so bad (text is a little small, but nothing serious). My netbook tends to slow to a crawl when playing the battles, but it works just fine when it comes to the turn-based segment.
Hopefully this is useful for others trying to get the game running.
Post edited October 23, 2009 by JoshoB
Thanks it kinda worked but gave me a head ache to look at the small figures in my dell mini
I did this and got it running, but it won't let me run it in full screen at all. I can use the highest resoluttion the game allows, just not in full screen.

At least it's running, thanks for the update!