It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Anyone else had this?
Yup. I got that as well.
Found an old thread which might have some solutions to the problems. Couldn't get links working in this post tho.

1. Try to launch gog galaxy as admin.

2. Disable antivirus software.
Also if this works and you have Avast, try to find a folder called "$AV_ASW" in your gog folder and then delete it. I think the post might mean the GalaxyClient folder but i am not completely sure.

The opening post in the thread got it working by changing the "Install game to:" and "Download games to:" folders to default and unchecking "Manage all folders manually". But i dont think that is a thing anymore.

Hope you guys get it working.