It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I can't start Icewind Dale on Linux Mint 20.2. After using "bash start.sh" in the terminal I got the error that the file "libssl.so.1.0.0" can't be found.

After going through quite a list of tips on the web (like extracting the missing file a deb repro and putting it into the /game folder I ended up adding an additional repro Ubunto 18 security somewhat and installing the package via apt.

I now have an different error message: "Running Icewind Dale: Enhanced Edition
./IcewindDale: error while loading shared libraries: libssl.so.1.0.0: wrong ELF class: ELFCLASS32"

I guess I would need the 64 Bit version? But this was choosen automatically by apt....

Does somebody happens to have a fool-proven way to get the game running on quite recent linux distros?

I can't have a computer without IWD:EE installed and I really don't want to buy the game on steam again!
There is some discussion in the Baldur's Gate forum here about a similar problem. Their solution likely would work for Icewind Dale also.
avatar
Retronade: After going through quite a list of tips on the web (like extracting the missing file a deb repro and putting it into the /game folder I ended up adding an additional repro Ubunto 18 security somewhat and installing the package via apt.
Please describe exactly what you did, so that someone else with your distribution could reproduce it without further research. This both helps others once we solve your problem, and helps us understand the current state of your system.
avatar
Retronade: I now have an different error message: "Running Icewind Dale: Enhanced Edition
./IcewindDale: error while loading shared libraries: libssl.so.1.0.0: wrong ELF class: ELFCLASS32"

I guess I would need the 64 Bit version? But this was choosen automatically by apt....
Yes, you must match 32 to 32 and 64 to 64. apt chose the version that it did without any awareness of why you wanted this old library, so it was not specifically constrained to pick a 32-bit version or a 64-bit version. You probably pointed to a repository of 32-bit libraries, so you received a 32-bit library.
avatar
Retronade: Does somebody happens to have a fool-proven way to get the game running on quite recent linux distros?
Wine. :)
avatar
Retronade: I can't have a computer without IWD:EE installed and I really don't want to buy the game on steam again!
Before buying on Steam, consider contacting the publisher to request that they ship a game that works as installed, without requiring user modifications afterward. openssl 1.0.x is very old, and they should have removed the dependency on it years ago (by upgrading to 1.1.x).
Thanks a lot for your tips!
avatar
advowson: Please describe exactly what you did, so that someone else with your distribution could reproduce it without further research. This both helps others once we solve your problem, and helps us understand the current state of your system.
Yes, you are right. My description was not very helpful. I had kind of rushed the whole thing and was frustrated that I couldn't fix it on my own. Next time I will be more systematic and write down the details.
avatar
advowson: Before buying on Steam, consider contacting the publisher to request that they ship a game that works as installed, without requiring user modifications afterward. openssl 1.0.x is very old, and they should have removed the dependency on it years ago (by upgrading to 1.1.x).
Yes, this is what I was going to do but then I had a quick look at steam yesterday night and saw the Autumn Sale. Now I haven't only IWD:EE already running on Mint but also the other three Infinity Enhanced Editions ready for the coming years :-)
Not exactly showing my backbone, I know, but switching to Linux as exclusive daily driver I have enough other issues to address as a newbie... And Steam is currently affecting the Linux community positivily, isn't it?
Thanks again a lot for your response!
Please download the older shared library from "downloads.dotslashplay.it/resources/libssl/"

Extract the 64bit version (libssl_1.0.0_64-bit.tar.gz) into the folder “/usr/lib/x86_64-linux-gnu”;

You will have to open the “/usr/lib/x86_64-linux-gnu” directory as a root user to put the files in it;

“ libssl_1.0.0_64-bit.tar.gz ” contains libcrypto.so.1.0.0 and libssl.so.1.0.0"
avatar
heater19: Extract the 64bit version (libssl_1.0.0_64-bit.tar.gz) into the folder “/usr/lib/x86_64-linux-gnu”;

You will have to open the “/usr/lib/x86_64-linux-gnu” directory as a root user to put the files in it;

“ libssl_1.0.0_64-bit.tar.gz ” contains libcrypto.so.1.0.0 and libssl.so.1.0.0"
While this might work, directing people to manually install a shared library in a system-wide directory is always the wrong advice, and is especially bad when the library is known to be outdated. The shared library should be installed by the system package manager, or should be in the user's home directory.
Ran into the exact same issue, decided to just install the Windows version via Wine instead. It's not going to be overly affected by any performance overheads and this way you get more consistent ability to run it across multiple distros.

I don't think installing an older library is the worst thing in the world, but it does indicate to me that the Linux client just isn't a priority in terms of support, and one dependency issue now will likely balloon into more down the line.
avatar
heater19: Extract the 64bit version (libssl_1.0.0_64-bit.tar.gz) into the folder “/usr/lib/x86_64-linux-gnu”;

You will have to open the “/usr/lib/x86_64-linux-gnu” directory as a root user to put the files in it;

“ libssl_1.0.0_64-bit.tar.gz ” contains libcrypto.so.1.0.0 and libssl.so.1.0.0"
avatar
advowson: While this might work, directing people to manually install a shared library in a system-wide directory is always the wrong advice, and is especially bad when the library is known to be outdated. The shared library should be installed by the system package manager, or should be in the user's home directory.
you're absolutely correct, my bad!
As others have mentioned, you can download the old libraries from downloads.dotslashplay.it/resources/libssl

I wouldn't recommend installing them into the system directory, as they are out of date libraries. Simply create a directory inside your game dir and tell the game to use that, by setting LD_LIBRARY_PATH.

In the following instructions, I have the game installed in '/opt/Games/gog/icewind-dale-enhanced-edition/', so change the path to fit your installation.

# Enter game directory
cd /opt/Games/gog/icewind-dale-enhanced-edition/
# Create 'libs' directory
mkdir ./libs
# Download libssl 1.0.0 and extract to libs dir
wget -qO- "downloads.dotslashplay.it/resources/libssl/libssl_1.0.0_64-bit.tar.gz" | tar xvz -C ./libs

Now run the game with LD_LIBRARY_PATH set to the libs dir inside the current dir ($PWD/libs)
LD_LIBRARY_PATH=$PWD/libs ./start.sh

You can replace $PWD with the absolute path to your install dir, if you want to run it from another location, such as a desktop shortcut.

If you don't want to download the files, you probably have them in a bunch of other games already on your system. if you have other older games installed of course.
If you have Lutris with the Steam runtime active they should be in ~/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu
The game can be run with:
LD_LIBRARY_PATH=~/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu ./start.sh

Lutris also supports setting LD_LIBRARY_PATH for the game, so if you choose to manually add the game to Lutris, you can define your LD_LIBRARY_PATH under Game options.
For some odd reason, Lutris doesn't seem to like if I set LD_LIBRARY_PATH to my existing steam library runtime dir, so I had to copy libcrypto.so.1.0.0 and libssl.so.1.0.0 into the 'libs' dir inside the game installation dir, as I mentioned above and then set that path LD_LIBRARY_PATH to that path, which to me was '/opt/Games/gog/icewind-dale-enhanced-edition/libs'

On a weird side note, after I tested both with my existing local files and the downloaded files and I tried copying them to various directories, including "~/.local/share/lutris/runtime/lib64/", my Lutris install started completely refusing to load the start.sh file, saying it couldn't be found, but after removing the game from Lutris and re-adding it, it no longer complains about the missing libssl libraries, even after I remove the library files from all the directories I added them to :D
I still have to add the LD_LIBRARY_PATH if I run it from the terminal, so clearly Lutris is adding SOME library path now, that It's just not displaying :)
Anyway, it works and I recommend you follow the above instructions to make it work for you and if Lutris suddenly stops loading the game, just remove it and re-add it. Lutris is a bit weird some times.
Attachments:
Post edited June 07, 2022 by gullilille
The LD_LIBRARY_PATH can e.g. be set inside the launcher file start.sh as I wrote here. The rest of the solution is quite similar.

By the way, this works for all the Enhanced Editions of the Infinity Engine games.
avatar
Retronade: I can't start Icewind Dale on Linux Mint 20.2. After using "bash start.sh" in the terminal I got the error that the file "libssl.so.1.0.0" can't be found.

After going through quite a list of tips on the web (like extracting the missing file a deb repro and putting it into the /game folder I ended up adding an additional repro Ubunto 18 security somewhat and installing the package via apt.

I now have an different error message: "Running Icewind Dale: Enhanced Edition
./IcewindDale: error while loading shared libraries: libssl.so.1.0.0: wrong ELF class: ELFCLASS32"

I guess I would need the 64 Bit version? But this was choosen automatically by apt....

Does somebody happens to have a fool-proven way to get the game running on quite recent linux distros?

I can't have a computer without IWD:EE installed and I really don't want to buy the game on steam again!
https://www.openssl.org/source/old/1.0.0/
Just in case anyone stumbles on this issue (like, me yesterday) and has trouble finding the files, I setup a small repo on github with files and instructions: https://github.com/xanathar/baldursgate_ee_libssl_files

Hope this helps somebody have fun.
avatar
MarcoMp: Just in case anyone stumbles on this issue (like, me yesterday) and has trouble finding the files, I setup a small repo on github with files and instructions: https://github.com/xanathar/baldursgate_ee_libssl_files

Hope this helps somebody have fun.
Cool. Are Jews allowed?
avatar
osm: Cool. Are Jews allowed?
UH?