It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I am running the GOG copy of Icewind Dale 2 on a Windows 10 Desktop (downgrading isn't an option), and I am having the following problem: it takes multiple, maybe 7-10+ key inputs before the game recognizes the key. Typing character names takes forever, and it makes inputting IPs, pausing, opening inventory, or using hotkeys impossible.

Most of the other threads talk about this issue with laptops, but I am not running on a laptop. Any solutions?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Lollercide: I am running the GOG copy of Icewind Dale 2 on a Windows 10 Desktop (downgrading isn't an option), and I am having the following problem: it takes multiple, maybe 7-10+ key inputs before the game recognizes the key. Typing character names takes forever, and it makes inputting IPs, pausing, opening inventory, or using hotkeys impossible.

Most of the other threads talk about this issue with laptops, but I am not running on a laptop. Any solutions?
Try DDrawFix.
avatar
Hickory: Try DDrawFix.
I already had this installed, and it does not fix the problem.
Post edited September 11, 2017 by Lollercide
avatar
Hickory: Try DDrawFix.
avatar
Lollercide: I already had this installed, and it does not fix the problem.
Do you have any kind of periphery, such as touchpad installed? They can often interfere with keyboard in some older games.
avatar
Hickory: Do you have any kind of periphery, such as touchpad installed? They can often interfere with keyboard in some older games.
As far as I know, I do not. The only thing that might be close to it is a controller I use for gaming, but it is unplugged.
I was having this same problem, tried a few different things and nothing seemed to work. The last thing I did was go into the Config.exe - Game settings and increase the "AI Updates per Second" from 30 to 40.

I've been playing for a few minutes now, and while I can't say that it's fixed as such, it does seem to have improved a great deal. The thing to remember is that the entire game moves faster (at 40, that's about a 33% increase), so you'll have to be a little quicker with your reflexes or the pause button at times.

It's also possible that in a little while it'll get really bad again - I've mostly only tested it by spamming the pause button so far.
avatar
KenrilZ: I was having this same problem, tried a few different things and nothing seemed to work. The last thing I did was go into the Config.exe - Game settings and increase the "AI Updates per Second" from 30 to 40.

I've been playing for a few minutes now, and while I can't say that it's fixed as such, it does seem to have improved a great deal. The thing to remember is that the entire game moves faster (at 40, that's about a 33% increase), so you'll have to be a little quicker with your reflexes or the pause button at times.

It's also possible that in a little while it'll get really bad again - I've mostly only tested it by spamming the pause button so far.
Increasing I.E. AI timing increases everything, affecting even things like time-sensitive quests. This has been known to break quests in Baldur's Gate; I don't recall if there are any that sensitive in IWD. The bottom line is those timers are not designed to be altered and shouldn't be changed from 30 for everyday play sessions.
avatar
KenrilZ: I was having this same problem, tried a few different things and nothing seemed to work. The last thing I did was go into the Config.exe - Game settings and increase the "AI Updates per Second" from 30 to 40.

I've been playing for a few minutes now, and while I can't say that it's fixed as such, it does seem to have improved a great deal. The thing to remember is that the entire game moves faster (at 40, that's about a 33% increase), so you'll have to be a little quicker with your reflexes or the pause button at times.

It's also possible that in a little while it'll get really bad again - I've mostly only tested it by spamming the pause button so far.
avatar
Hickory: Increasing I.E. AI timing increases everything, affecting even things like time-sensitive quests. This has been known to break quests in Baldur's Gate; I don't recall if there are any that sensitive in IWD. The bottom line is those timers are not designed to be altered and shouldn't be changed from 30 for everyday play sessions.
I'd never claim it was an ideal solution, but if the game isn't registering your inputs half to two-thirds of the time (as it was for me), it may be preferable.