It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So after reading the last threads about this issue the reason these Mouse lag spike is causing is mainly because the game is uncapped which is in fact correct.

So,I kinda found a Solution for this,doubt its permanent but the difference is noticeable so expect crashes or bugs.

First download the latest 3.0 version of this game here
igi2isfkinder.weebly.com/igi-2-stuff.html

Then download the Latest RivaTuner Statistics
guru3d.com/files-get/rtss-rivatuner-statistics-server-download,16.html

Before running the software,make sure you in-game not in main menu.
Then run the software
The enable Stealth Mode and Show own Statistics to check your current frame rate.
(Before locking the frame rates,you can see how the frame rate jacks up to over 200+ mostly in indoor areas and levels.This is the reason why the mouses skips and makes it harder to shoot.)
Once you enable those two,set the Framerate Limit to 60.
Now that it's locked,you can play this game at locked smooth 60fps while also partly fix this annoying bug.
Enjoy,hopefully this helped.

This is the tutorial video that helped so if anyone wanna check it out here
youtube.com/watch?v=raEg3GiT57I