It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Anyone know how to get this to work with EAX via Creative's Alchemy? None of the settings I tried so far made any of the three EAX options selectable.
I know it's been a while, but GTA3 had the same problem (and same sound driver - MSS), and last year someone created a patch for it, so mss.dll would look for dsound.dll (which is alchemy's wrapper). It worked like a charm in GTA3, but crashed with an error in IGI2. But I bet you could ask them to adapt the patch for IGI2 as well.
Here's the (temporary) solution for enabling EAX effects in this game.

Tested on X-Fi Platinum Fatal1ty. Please leave your feedback in case of any problems, I'll try to make it better.

www75 . zippyshare . com/v/LPw2mFWj/file.html
Post edited February 19, 2020 by SubV242
Another way to load alchemy dsound.dll without using dll injection programs is using a manifest file. Please keep in mind that you need to embed a manifest file to game exe. You can do it by using a tool named mt.exe (Microsoft Manifest Tool) which can be found in C:\Program Files (x86)\Windows Kits\10\bin\10.0.18362.0\x86\mt.exe if you have Visual Studio installed.

Steps to fix dsound loading:
- Install alchemy dll file into game folder using ALchemy.exe gui
- Create a new file named "igi2.exe.manifest" in a game root folder with content:
- Open a console (cmd or wt or "Developer Command Prompt" if you familiar with that stuff) and navigate to your game folder
- Run mt tool: mt -nologo -manifest igi2.exe.manifest -outputresource:igi2.exe;#1

After that try to run a game and see if you can set EAX3 in Audio settings.