It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Crashes at startup (worked fine until i updated all software using pacman -Syyu)

$ ./
Running Hollow Knight
Set current directory to /home/user/GOG Games/Hollow Knight/game
Found path: /home/user/GOG Games/Hollow Knight/game/hollow_knight.x86_64
Mono path[0] = '/home/user/GOG Games/Hollow Knight/game/hollow_knight_Data/Managed'
Mono config path = '/home/user/GOG Games/Hollow Knight/game/hollow_knight_Data/Mono/etc'
Preloaded ''
Preloaded ''
Preloaded ''
Logging to /home/user/.config/unity3d/Team Cherry/Hollow Knight/Player.log

at (wrapper managed-to-native) UnityEngine.Input.GetJoystickNames () <0x0005c>
at (wrapper managed-to-native) UnityEngine.Input.GetJoystickNames () <0x0005c>
at InControl.UnityInputDeviceManager.QueryJoystickInfo () <0x0001c>
at InControl.UnityInputDeviceManager.Update (ulong,single) <0x00078>
at InControl.InputManager.UpdateDeviceManagers (single) <0x00081>
at InControl.InputManager.UpdateInternal () <0x000fc>
at InControl.InControlManager.Update () <0x00049>
at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0x0005e>

Native stacktrace:

/home/user/GOG Games/Hollow Knight/game/hollow_knight_Data/Mono/x86_64/ [0x7f6d5333843a]
/usr/lib/ [0x7f6d5881e7ff]
/usr/lib/ [0x7f6d58329ce5]
/usr/lib/ [0x7f6d58313856]
./hollow_knight.x86_64() [0x9e3cdb]
/home/user/GOG Games/Hollow Knight/game/hollow_knight_Data/Mono/x86_64/ [0x7f6d53378c70]
/home/user/GOG Games/Hollow Knight/game/hollow_knight_Data/Mono/x86_64/ [0x7f6d532d713e]
/usr/lib/ [0x7f6d5881e7ff]
/usr/lib/ [0x7f6d5844f1e5]
./hollow_knight.x86_64() [0x12bed9f]
./hollow_knight.x86_64() [0xa7b3d6]
/home/user/GOG Games/Hollow Knight/game/hollow_knight_Data/Mono/x86_64/ [0x7f6d532db296]
/home/user/GOG Games/Hollow Knight/game/hollow_knight_Data/Mono/x86_64/ [0x7f6d533ddad4]
./hollow_knight.x86_64() [0x9a5263]
./hollow_knight.x86_64() [0xa08524]
./hollow_knight.x86_64() [0x9e1f36]
./hollow_knight.x86_64() [0x5f6649]
./hollow_knight.x86_64() [0x802926]
./hollow_knight.x86_64() [0x45fab8]
/usr/lib/ [0x7f6d58315022]
./hollow_knight.x86_64() [0x46d2b8]

Debug info from gdb:

I refuse to debug myself!
No threads.

Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

./ line 16: 194429 Aborted (core dumped) ./"hollow_knight.x86_64"

I have the exact same problem

- GPU : radeon HD 7950 (ati driver)
- CPU : FX 6300
- OS: Arch 5.6.3

What I've tried:
- 1: Installing the GOG version from Lutris or GameHub
- 1.1: Tried to launch the game with and without a controller
- 1.2: Tried to update my distribution
- 1.3: using the -noheap option mentioned in the steam FAQ thread

- 2: Installing the windows version from the GOG website executable directly (without using GOG Galaxy as it does not run well on linux)
- 2.1: tried using x360ce software
- 2.2 : tried launching the game within steam

For attempt number 2, the game works very well with wine (good performances, no lag, all cool) BUT my xbox controller inputs are not mapped correctly: for instance, my right joystick is mapped to the left D-Pad, and my right trigger is mapped to the right joystick Y axis. I am not able to change the controller's mapping with x360ce, so my character always looks up (because of the right Y axis being mapped to the right trigger).

I am aware the game might be unmaintained or this particular bug might not be interesting as there are workarounds (using wine version with keyboard instead of xbox controller), but if anyone has a solution, please let me know :)

I used the GOG forum because the link is not working for me (which made me think the team will not try to fix the bug).

Thank you for your time
Post edited April 11, 2020 by Shumush
I just installed this in manjaro, and noticed that it will only start when Steam is not running. It seems the libraries conflict or something.
Crash on launch with this game, especially on rolling releases like Manjaro, can be due to this Unity3D bug: Common issues with Unity3D - Crash on launch if pulseaudio is not running