It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey there.

I owned the original retail game for some while and it worked on my Windows 10 just fine.

I then re-bought it again on GoG, but now the game refuses to launch. I tried to disable DirectPlay, play with no antialiasing, disabled fullscreen... nothing works.

I looked into the log text file that got created in my H&D2 folder and it says:

"Date: 05/09/17 time:05:39:10
LS3D Engine V5.59.5 Aug 16 2004 GetVer:559

ERROR! DirectX version is lower than 8.1 !"

Weird thing is, I just noticed I cannot play Chameleon either (another game by Illusion Softworks, running on the same enigne). And both of these games worked like 2 days ago.

Only thing I did was updating my NVIDIA drivers, could that be possibly the culprit?

Thanks in advance for any help!

EDIT: And now the game dissapeared from my "Installed" tab as if it was never installed (but the folder is still there). What the heck is going on with this game? D:
Post edited May 09, 2017 by The_Vityaz
Okay whoa, managed to figure it out. Hopefully, this could help others as well.

I have an NVIDIA Graphics card (860M GT) and updated my drivers 2 days ago to the newest version (382.05).
Turns out that since I did that, LS3D engine games (Chameleon, H&D2 and possibly the first Mafia or VIetcong 1) completely refused to work due to the alleged DirectX 8.1 error.

Afterwards, all I did was reverting to the driver version before (381.65) and it started working again.

I don't know what they did in the newest one, but it doesn't seem to play well with the old LS3D engine.
Post edited May 09, 2017 by The_Vityaz
Whops, doublepost. Sorry bout that. Anyone knows how to delete a post?
Post edited May 09, 2017 by The_Vityaz