}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
/!\: This thread is not kept up-to-date anymore, please go to the following one to get the latest links and instructions, or for any kind of feedback on the scripts:
[./play.it] Install the Heroes of Might and Magic games on Linux

-----

Hello fellow Debian users, Ubuntu lovers and Mint freaks!

Here you’ll find scripts allowing you to build a .deb package from your Windows installer of Heroes of Might and Magic 3. You can then install it through DPKG and remove it through any APT front-end (apt-get, aptitude, synaptic, etc.).

Download links and usage instructions can be found on the following page:
Heroes of Might and Magic 3

I hope you’ll enjoy these scripts as much as I enjoy writing and tweaking them ;)

-----

Here you go for more supported games!
Post edited May 06, 2018 by vv221
Hi vv221,

I try to follow your link to turn my Heroes III installer to deb. Unfortunately, the download links in debian-facile.org give me error 404. May I request for those files to be reuploaded? Every help will be appreciated.

Thanks in advance.
avatar
janet_ulung: (…)
Thank you for the report, I updated the link in the first post of this thread.
Is there an easy way to also add the HD mod or Horn of the Abyss mod?
When I follow the instructions (also giving the scripts +x option), I get the following error upon play-heroes-of-might-and-magic-3.sh execution:

Using setup_homm_3_complete_4.0_(10665).exe
Checking integrity of setup_homm_3_complete_4.0_(10665).exe OK
Extracting data from setup_homm_3_complete_4.0_(10665).exe
warning: unexpected setup data version: 5.5.7 (unicode)
warning: unexpected Auto Boolean value: 20
warning: unexpected Architecture flags: 10
warning: unexpected data while converting from CP1200 to UTF-8
stream error: basic_ios::clear
Done with 1 error and 4 warnings.


Does anyone know what to do?

I use XUbuntu 14.04.
Amazing what you did OP! This is one of the best games ever and I really appreciate your input. However, due to your recent upgrade of the scripts, in Ubuntu 16.04 LTS, the version for the innoextract is too low and the extraction stops very soon. However, a higher version of innoextract can be installed through a ppa repository. Instructions can be found and this link :

linuxhelp...com/how-to-install-innoextract-on-ubuntu-16-04/

Since I cannot post links, just remove the extra dots before com.

The script requires innoextract 1.6/ 5.5.8 and ubuntu 16.04 gives by default only 1.5 / 5.5.6. So you need to use the repository in that link and reinstall innoextract and just follow the rest of the instructions from OP. Everything works after that.

Cheers
avatar
MarkoF: (…)
avatar
Sorin-fratila: (…)
I do not follow this thread anymore, that’s why I missed your reports.
See here for a solution to your issue:
https://www.gog.com/forum/heroes_of_might_and_magic_series/playit_install_the_heroes_of_might_and_magic_games_on_linux/post23
Post edited May 06, 2018 by vv221