It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello

I've recently installed Heroes of Might and Magic® 3: Complete and while I can play the normal game just fine, I'm unable to play multiplayer. I can get as far as the screen where you select the various multiplayer options (see attached pictures) however trying to use any of them immediatly causes my game to crash with the following error message.

DirectPlay Error:

'Uknown error?'

File'C:\Dev\Heroes 3 Exp 2\game\Remote.cpp'
Line# 1867

I've tried downloading directX End-User Runtimes, reinstalling/verifiying the game, running as admin and various compability modes, however no luck.

I use Windows 10 by the way.

Any ideas?

Thanks in advance.

Edit: I've also tried adding an exception/disabling my firewall, however since the game crashes before I can get to the host/join screen I doubt it's a connectvity issue.
Attachments:
heroesmp.png (406 Kb)
Post edited May 21, 2017 by aggramar.939
No posts in this topic were marked as the solution yet. If you can help, add your reply
Disable User Account Control on both computers. Instructions are here, use the second tip.
With who are you trying to play against ? Because judging by the heroescommunity community in this thread the problem it seems to be where you or your opponent don't have the same version of the game.

http://heroescommunity.com/viewthread.php3?TID=12141&pagenumber=5 (Page 5)
http://heroescommunity.com/viewthread.php3?TID=12141&pagenumber=6 (Page 6)
Post edited May 22, 2017 by Damien.01
avatar
aggramar.939: Hello

I've recently installed Heroes of Might and Magic® 3: Complete and while I can play the normal game just fine, I'm unable to play multiplayer. I can get as far as the screen where you select the various multiplayer options (see attached pictures) however trying to use any of them immediatly causes my game to crash with the following error message.

DirectPlay Error:

'Uknown error?'

File'C:\Dev\Heroes 3 Exp 2\game\Remote.cpp'
Line# 1867

I've tried downloading directX End-User Runtimes, reinstalling/verifiying the game, running as admin and various compability modes, however no luck.

I use Windows 10 by the way.

Any ideas?

Thanks in advance.

Edit: I've also tried adding an exception/disabling my firewall, however since the game crashes before I can get to the host/join screen I doubt it's a connectvity issue.
I had this issue as well and tried numerous suggestions. The solution came from GOG support team:
avatar
Plokite_Wolf: Please try to enable DirectPlay:
Please open Run Command (you can do it by pressing WinKey+R) - > type: control - > press ok - > go to Programs - > Programs and Features, click the Turn Windows features on or off link, find the Legacy components on the list, enable DirectPlay and click OK to install it.
avatar
aggramar.939: Hello

I've recently installed Heroes of Might and Magic® 3: Complete and while I can play the normal game just fine, I'm unable to play multiplayer. I can get as far as the screen where you select the various multiplayer options (see attached pictures) however trying to use any of them immediatly causes my game to crash with the following error message.

DirectPlay Error:

'Uknown error?'

File'C:\Dev\Heroes 3 Exp 2\game\Remote.cpp'
Line# 1867

I've tried downloading directX End-User Runtimes, reinstalling/verifiying the game, running as admin and various compability modes, however no luck.

I use Windows 10 by the way.

Any ideas?

Thanks in advance.

Edit: I've also tried adding an exception/disabling my firewall, however since the game crashes before I can get to the host/join screen I doubt it's a connectvity issue.
A bit late answer, but I had exactly the same problem as you did. And I found a solution for it. All you need to do is go to Control panel > Programs and features > Uninstall or change program, and there on left you find "Turn Windows features on or off". When there find "Legacy Components" and under there mark DirectPlay to turn it on.

I hope this'll help if someone is having similar problem.
Post edited July 02, 2017 by Kndmursu
avatar
Kndmursu: A bit late answer, but I had exactly the same problem as you did. And I found a solution for it. All you need to do is go to Control panel > Programs and features > Uninstall or change program, and there on left you find "Turn Windows features on or off". When there find "Legacy Components" and under there mark DirectPlay to turn it on.

I hope this'll help if someone is having similar problem.
I was having this problem today and after trying a lot of things that didn't work, this did it for me. Thank you for posting this solution here!
Post edited September 13, 2017 by Strieko