It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


I just bought this game during the sales and finally found some time to test it.
But sadly it instantly crashes when I launch it.

I got Win 8.1. I think that falls under "runs on win8" though.
I have 3 monitors.
Since I read it runs on the wrong monitor from time to time, this might be a problem.
In fact when I run in full screen it starts on my 3rd monitor. That's the one on my cpu integrated gpu.
I hoped it would run in windowed mode but that had the same effect, except for crashing on my primary monitor instead of my third.
Any help/suggestion would be very appreciated. :)
No posts in this topic were marked as the solution yet. If you can help, add your reply
I play this game on fullscreen at 1280x1024, for when I use the maximum resolution, which is 1600x1200, the game crashes instantly on fullscreen mode. It's not possible for me to play on windowed mode because of how slow it is.

When I run on fullscreen, the game always ends up on my second monitor for some reason. I usually just disable it while playing, especially since it's not recommended to alternate between applications while running this game, for it may cause graphical artifacts or stuff like that, if I remember correctly.

I've also managed to play without stretching by following these steps. This won't work as intended though, or at least it doesn't for me, if you run the game on a monitor other than your main display, that's the main reason I always disable my other screen.
OS: Windows 7 64-bit SP1
CPU: Intel Core i7-2600K
RAM: 32,00GB
GPU: GeForce GTX 580 x2 (disabling SLI doesn't seem to change anything for me)
Post edited June 07, 2014 by ASnakeNeverDies