It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello.

I went to the arena in Kyallisar to see if there are any new opponents I can fight. Before talking to the guard I always saved the game. This time, a glitch caused me to get stuck in the ring, but there is no one to fight. I quick saved before noticing this and can't get out. I don't want to use an even earlier save because I just spent almost an hour looking for loot to sell and getting atunements, saving only using F5. Is there any way to fix this? Thank you.
This question / problem has been solved by Garranimage
You can try walking around in the arena to see if something happens, or reloading the existing savegame to see if the script fires, but unfortunately, you're probably going to have to roll back to an earlier save.
Thank you for your reply.

I tried that. I also tried replicating what I did, but moving in the opposite direction. I looked for a cheat to teleport elsewhere but there doesn't seem to be one. Oh well. It's just a game. Thank you again.