It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I installed the game and noticed that in the games installation folders, there is a file "settings.cfg" where you just have to change one number to have another language :D
I tried for french in HoI 2, it seems to be working without any trouble !
Thank you for this information!